Modifying styles globally

Probably a Mac question, rather than Scrivener-specific. It’s also pretty basic and I can’t believe either I or Apple are so stupid not to have worked this out.

I created a custom style within Scrivener, but I now want to change the font. The only way I can think of to do this is to select some text, change the font, invoke the Style dialog, click the ‘add to favorites’ button and replace the original style (how unintuitive is that?).

The problem is that this does not change all instances of this style previously created in the project - it only changes the selection.

Do I have to reapply the style to every instance? Surely there’s a way to update styles globally?

Also I don’t know how to find out what style is currently applied to a particular selection.

From the FAQ:

Thanks AmberV,

I’ll be sure to check the FAQ first before I post here in future!

Would it work to make the changes you want in the “Text Editing” pane of the Preferences and then use “Document : Convert : Formatting to Default Text Style” menu option … perhaps having selected all the appropriate documents in the binder?

I’ve never done this, so I don’t know if it would work … On the other hand, Amber would know, and as she hasn’t suggested that, perhaps I’m wrong.


That would certainly change the font and ruler settings for everything selected, however it does so in a “scorched earth” manner. This tool is primarily for normalising stuff you’ve collected from other sources—or if you’ve changed your mind about a favourite font and want to update old projects. You will lose all special format rules like block quotes, headers, and so forth. You will not (assuming your preferred font supports the appropriate variants) lose italics and bold.

So approach that tool with caution. It’s for adjusting the entire document, not just specific blocks of it. Otherwise, if that is what you wanted to do, then yes that is exactly what you are looking for.

Thanks xiamenese, but my question has been answered to my satisfaction.

FYI I had originally created a favorite ‘style’ (indented and italic) for quotes, then came across some italics in a quote and had second thoughts. I have resolved the issue by making italics in quotes into regular text!