monospace font when compiling for Kindle?

I have a small question (I hope!). When I use Compile to make a .mobi file for Kindle, the font in my compiled .mobi file has a different font than it did before the recent upgrade. The new font looks like Courier, but I really prefer that my compiled file use the font that it used to come up as–I believe it was Georgia (?).

Anyway, I was looking through the recent log of what was upgraded and noticed this:

“When exporting to e-books, text that uses a Courier, Courier New or Monaco font is now set to use the e-reader’s monospace font.”

So, is there any way I can set Scrivener to not default to the monospace with .mobi? Or, could I change my fonts in Scrivener so that they won’t change to Courier (or the e-reader’s monospace font) when I compile? (I know it’s nitpicky–sorry. I just really dislike monospace fonts and I feel like most readers don’t like them, either.)

I’m currently using Cochin as I write in Scrivener. If I used Georgia would that resolve this issue?

Cochin won’t become monospace - only Courier, Courier New and Monaco fonts will be converted to monospace. My guess is that you have the “Formatting” pane of Compile set up to override the font with Courier - try un-ticking the “Override text and notes formatting” button, for instance.

All the best,

Yes! That was it! Thanks a lot for the fix.

Hooray for this thread. The same thing happened to me (optima compiling in monospace after the update) and unchecking the box solved my problem. Mostly.

Section headings still compile in monospace. Oddly, the section headings show as lucida grande in the binder, but when I look at them in index card format, font showed as courier. Went and changed it in the preferences anyway but still compiles in monospace.

I’m probably missing something obvious…

Check the Formatting pane in the compiler, that is where the actual headings format is determined. The display of them in the interface itself is just for your benefit. After all, 24 pt bold titles in the binder would look awful. :slight_smile: