moving outline from omnioutliner to scrivener

If I export from omnioutliner (OO) in rtf, then inport into scrivener (S), all the outline text is there, collapsed and expanded as it was in the export, but none of the parents can be collapsed or expanded.

If I export from OO in OPML, then import into S, the outline is in binder and can be collapsed and expanded, but in the outline view, each of the bottom level children shows up under their parent as a file name, one line to each.

Is there anyway to turn on word wrap in outline mode so each of these bottom level “filenames” shows up in its entirety in outline view?

Is there any way to have the bottom level children be separate paragraphs in their parent files, as text not filenames?

That should already be happening in the Outliner view. In fact it is impossible to turn off word wrap on titles and synopses. Or maybe you mean in the Binder? There is no wrapping in the Binder, which is meant to be your central “map” of the whole project. Think of the Binder as being a more powerful Contents sidebar from OO. If you intend to work with a chunk of outline, it will be easier to do that in the large editing area to the right of the sidebar as you would in OO—but unlike OO you do have the option to outline and edit your outline freely in the sidebar as well. Try clicking on a group of items in Scrivener and then hitting Cmd-3 or using the View/Outliner menu command. As with OO’s Contents bar, clicking on groups in this view will hoist the main editing area on the right. You should hopefully find it all very familiar once this conceptual adjustment is applied to Scrivener.

Since both OmniOutliner and Scrivener are outlining programs, and OPML is an outlining format, yes—outlines should be conveyed between the two programs as closely as the format allows for. My question would be, if these things are outline elements in OO, why would they not be outline elements in Scrivener? Both programs work the same way with regards to breaking down things into topical trees and to work a larger body of text via that tree. There are of course many legitimate reasons to destroy outlining data as a project progresses, I’m mainly asking because it is not an uncommon misconception that Scrivener’s Binder is a kind of “super Finder”, but it is an outliner and its Binder can definitely be used to hold “bullet points” just like in OO. It’s not a “filename”, it’s a “title”, just like in OO.

That all said, if you need to discard that information, that is what the Documents/Merge tool is for.

I have a strategy for doing this, because I wanted it also. In fact, my strategy is somewhat more general. The subtree under any node of your outline will be turned into document text if the node text contains the subsection symbol (opt-6).

To use this technique, you need two things: i) to be able to copy your outline to the clipboard as a tab- or space-indented outline and ii) my Applescript script which converts your text that is on the clipboard into a form Scrivener can import, making hiearchical docs of your outline nodes until it hits those tagged nodes, then fills those node documents with your suboutline text.

I can share that script (the code of which would be open to your inspection, for your safety) if that sounds like it would do something useful for you.

Greg

AmberV -

"That should already be happening in the Outliner view. In fact it is impossible to turn off word wrap on titles and synopses. Or maybe you mean in the Binder? ’

(Don’t know how to do fancy quote - quote button grabbed whole reply)

No, I’m talking in the edit window/pane, and the text only displays from the file symbol to the synopsis column. The rest of the text is hidden, because S thinks of it as a file, rather than text within its parent file. If that item would wrap, and take four or 5 lines in the edit pane if needed, I would be fine.

But also, everytime I select a different item in binder, S goes out of outliner mode and I have to re-click on outline in the toolbar. Locking the toolbar has no effect on this. How can I lock S into outline mode?

gr - Yes, I would like to try your script.

gred22,

Attached zip contains that applescript in both .scpt and plain text forms. There is an overview of the idea plus some adjustable parameters in the script file. I’ve included a sample dummy outline text file as well as the converted output you would get from it (and which would be imported into Scriv as Multimarkdown).

Hope you find this useful. I certainly do.

-gr
Map or Outline to Scriv.zip (34.2 KB)

gr,

thanks for the files. Your samples were very helpful understanding the function of this. And it looks very useful for what I want to do.

I still find it annoying that scrivener switches out of outline mode everytime I select a different item in binder. I want to be able to lock it into outline mode. Should I start a separate thread on that?

Should I start a separate thread on the word wrap issue as well. It would be so helpful if the entire imported node would display in the editor pane even when longer than the one line of “title”.

You can set your preference on what you wish to see by default in the editor when you click on a folder in the binder. Choices are the text content of the folder itself (not usual), the corkboard view, or (ta-da!) outline view. Now, if I could only remember how you set that preference – I did it so long ago for myself (just a fellow scriv user here). I have a vague impression that you could “infirm” your preference by clicking that choice on the little tripartite view-mode doohickey n the toolbar with a modifer key held down – ah, but which modifier? That is the million dollar question. [UPDATE: There was no secret to it. Just set it and forget it – Once you pick it, Scriv just keeps doing it that way until you say different.]

gr

P.s. Unless what you are wanting is to lock the outline view you have against clicking on anything in the binder, in which case what you want is to Lock that editor. (Clicking around in the Binder doesn’t do to much then unless you have a split editor view going, so binder taps can still effect the unlocked editor view.)

I know how to lock the editor, then that editor pane stays the same, and no selection in the binder changes it at all.

It sounds like what I need is how to set the preference on editor view to outline, but I can’t find it. Anyone have the key???

So, okay, I finally got back to my desktop and here is what I am seeing…

If I select a FOLDER in the Binder and then change the View Mode to Outline, then from then on (in that project), clicking on folders in the Binder will show their contents in Outline mode. In short, my preference for seeing outlines for folder contents is thereby set. So, that should be working for you already.

This same strategy does not work for Container Documents. If you have a container doc selected in the binder and choose to view its contained items in outline view, this will not have the effect of making the next container doc you click on show outline view by default. This is a difference in the treatment of folders and container documents.

So, is the latter the sort of case where you find you keep needing to reassert Outline view? Or is it something else?

-gr

Yes, that is the key!!! If I convert the files (set thusly in Omni outline export/ Srivener import) I want to stay in outline mode to folders, it stays in outline as I select different folders in the binder. Thanks so much.

Now if I can just learn how to get word wrap in the outline view of the editor I’ll be all set.

In Outline view, the Title field does not wrap unless you have the ‘And Synopsis’ view option also chosen. When both are showing, both fields wrap to the width of their joint column.* In fact, the point is general: if And-Synopsis is showing, the keywords field, for example, wraps to its column; when synopsis is not showing, it doesn’t. I have no idea why outline view behaves this way and had not noticed it before. (Bug or feature; you tell me.)

-gr

  • Your description of circumstance refers to a synopsis /column/ to the right of your title column. That puzzles me, because having them occupy separate columns is not even an option as far as I can see. Or if it is, turn it off!

When outlines are imported Scrivener uses text items to build the outline. Folders in Scrivener are a special concept, a regular old outline item just like all of the rest, but with a built-in concept of being a “group”. If you take file files and nest them beneath another file, this is a group, but by default the software will treat the click as a normal text item click.

You can change that in the Navigation preferences pane, with the Treat all documents with subdocument as folders checkbox. I use this setting myself, I’ve never cared to distinguish between folders and file groups when it comes to navigation. But if you would like that distinction then you can tell Scrivener to treat containers as groups by converting their type from file to folder. Just right-click on the parent item and select Convert to Folder. Now when you click on it you should see an Outliner view (or whatever your current view mode is set to).

Placing the Synopsis in a separate column is only possible in Scrivener 1.x for Mac and Windows. The 2.x model combines these two pieces of information into one field (with the option to disable synopses display). To the OP, are you using a really old version of Scrivener? Here is what you should be seeing:


[size=80]The underlying screenshot has synopses enabled, the front has them disabled.[/size]

Thanks for your assistance and patience gr and AmberV.

Yes, checking "treat all docs w sub docs as folders does what I wanted without having to convert the files to folders, it appears.

A confusion factor is that I have both mac and PC versions of Scrivener. Obviously omnioutliner is on the macbook air, but the exported file I imported and am working with on the PC, because I have two large monitors on it. You are correct that it shows the synopsis as a separate column, and indeed it is version 1.9.0.0. But it tells me it is up to date when I check, and the date on the 1.9 is 10/6/15.

Any further advice?

It’s important to get this working for me, because I am working on a book and want to move to using scrivener for all of it. The reader’s digest version is I had over 300 pages of research and notes in EccoPro on a PC, and could not readily import into omnioutliner, but started using omino for the book outline, but now want to use scrivener for the outlining and writing of the book. I refer to the research and notes back in Eccopro on the PC, but had issues with colored text in omnio. I can export the ecco files into html and maintain the expand and collapse capability, but the rtf export is flawed and does not preserve that in omnio. I plan to investigate putting the html files into scrivener to eliminate the need for eccopro.

thanks again

Ah. I think neither of us knew you were working with the Win version (b/c the platform in your profile just says mac and, well, you posted in the mac tech support forum :wink:.)

I guess outline material in n EccoPro should have been readily exportable to OO, since EccoPro can export as tab indented. OO should import tab-indented outlines no problem.

–gr

Sorry for the delay - had to deal with flooded basement.

Returned to Macbook Air, although I miss the big monitors on the PC, and by changing the Navigation preferences pane, with the Treat all documents with subdocument as folders checkbox, and exporting omnioutline in opml then importing into Scrivener, it does everything like I wanted.

It shows the outline and can expand and collapse without changing everything to folders, it stays in outline mode after selecting different items in binder, and it has word wrap of what are now titles rather than text, for children items of the omnioutline outline.

Thanks again for your assistance.

One last issue. When I had to export from omnioutliner in OPML rather than RTF, I lost all the colored text’s colors. This was the same reason I had wanted to export eccopro in RTF rather than simple tab delimited - to preserve the colors.

But, when I go to change the color of the text of what is now a title in Scrivener, I cannot change the color of the text. I select the text, then select the color I want from the drop down in format, but everything remains black. What am I missing?

I am not even sure how you got the Format Bar activated while editing the Title (in Scrivenings mode perhaps?), but there is no way to format titles like that in the first place, they are simple text, as is the Synopsis field.

But you can still color code the items in the binder – just not the way you are trying to do it. Applying a Label to a binder item tints the item with the color associated with that label (though you have to enable this functionality by a menu choice saying you want label colors to have this effect).

gr