MultiMarkdown 2.0.a1 Released

I have (quietly) uploaded the latest version of MultiMarkdown to my website:

You can add this to Scrivener if you like:

(Make a copy of Scrivener first, just in case)

  • Download the above zipfile

  • Unzip it

  • Optionally, you can make a copy and remove the documentation folder

  • Find Scrivener

  • Right-click and select “Show Package Contents”

  • Navigate to Contents-> MacOS

  • Replace the “MultiMarkdown” folder inside Scrivener with the “MultiMarkdown” folder you downloaded (or the documentation-less copy if you choose)

(Make sure the MultiMarkdown folder name is not changed - if you aren’t sure, you can simply drag the bin, MultiMarkdownMath, etc folders and replace the old copies.)

While you’ve got this open, take a look in the XSLT folder - these are the new goodies as far as different LaTeX output types.

Updated documentation is coming (I’ve got to finish writing it in Scrivener… ;:wink:

In a nutshell, the big new features are:

  • poetry mode = the poetry flavored xslt use a regular typeface for “code blocks” allowing you to use them as regular verbatim boxes. Essentially you can type the spaces as you want them to appear in the output

  • 2 flavors of manuscript format export. manuscript-novel is a version I came up with to try out some things. It’s not perfect, but it works for me. sffms is an XSLT to convert MMD to a format suitable for the sffms class off the internet. You must install this class if you want it to work. ( )

  • The article format is now built using the article option in memoir, rather than the article class. This adds some extra features, and makes the two modes more compatible.

  • The 6x9book format, which is the updated version of what I basically used to create a book from Lulu. Disclaimer - I tweaked the margins since I printed my copy. It should be better, but I have not purchased a copy using this template. Proof the entire thing before you send your pdf. Make sure you know what you are doing. Don’t blame me if things don’t print as you expect. Again, it worked for me, but I make no promises. That said, if you do have trouble – PLEASE LET ME KNOW SO I CAN FIX IT!!!

  • There are some new features available, including a glossary syntax. This is not documented yet, and you need to be able to get glossaries to work in memoir on your own. I will post simplified instructions with the new documentation, but this is sort of an “advanced” feature.

  • a lot of “minor” bugfixes are included.

At some point I make to make an installer script to update the MMD folder inside Scrivener for you. If someone else is interested in creating this, let me know what you come up with, and feel free to share with the rest of the class. It may take me a while to get around to creating something like that.

When a footnote is a glossary type footnote, it is missing the opening



  • Glossary footnote. :leftwards_arrow_with_hook:

  • Regular footnote.

  • [/code]

    Looks like the bug is on line 1787 of

    Right on! I just tried out the 6x9book format, and it looks good so far.

    I do have one question though, I’ve heard about lulu (or rather, some of their printers) not printing properly from a latex-generated pdf; did you have to do anything or could you just send your pdflatex output directly to them?

    Also, I don’t seem to have the printglossary command installed. I guess if there are no entries in the glossary, it won’t print anything at all (once I get the right package installed)?

    Huh - there actually seems to be a bigger issue with the matching. I’ll have to work on this part. As you can see above none of the glossary specific spans in the glossary footnote. (Extra markup gets added to glossary items so that the XSLT can handle it properly)

    The problem has to do with fonts. If your latex pdf references fonts that lulu doesn’t have that aren’t contained in the file, then things don’t go so well.

    I had no trouble with the pdf taken straight out of pdflatex. I had tested a few other ways of doing things, which seemed to generate messier pdf’s so I went with the straightforward approach. And it seemed to work.

    But since I have only done it one, your mileage may vary…

    (The front cover is a different story, remember that the cover is basically a bitmap in pdf format, so fonts don’t matter.)

    As for the glossary, it should fail silently if there are no glossary entries. It’s actually set up using a feature in the memoir class, not a separate package. But you have to run a command line during latex processing to get it to work. I’ll document later, but if you’re interested now google memoir glossary and basic.gst.

    Ok, so pdflatex does include the fonts in the file? I guess it would have to, as I don’t think Computer Modern is a standard install item on most computers, and you can open LaTeX PDFs on any computer…

    Hm, would this be an issue with the memoir class in the MacTeX distribution being excessively old? (As discussed in the tips & tricks forum…)

    I had noticed that, but did not mention anything. I thought maybe you were doing some voodoo from the referencing glossary class pointer link – which was assigned correctly in the output. So I know I am using the syntax right, it is just not matching everywhere, like you say.

    Exactly - I think the basic fonts are ok, but if you use any others, you need to follow the directions on Lulu’s site. I tried my pdf’s on a couple of computers and operating systems before uploading. And make sure to buy a test copy first…

    Perhaps - definitely upgrade memoir. I have tried to minimize the external modules I use, and most (if not all) are in a base install of MacTeX. But you need to upgrade memoir, because they have an old version for some reason… But the glossary shouldn’t cause any problems if you don’t use it.

    Ok, I’ll have to try that again. Only this time I’m going to do a bit more research before dumping the newer memoir style in the directory. I didn’t have so much luck last time, and ended up re-installing MacTeX to get my old install back. The one that only had the ifpdf error… But that’ll be for another day. The PDF is generated just fine if I press enter and let pdflatex keep going.

    Keith (or Fletcher or AmberV) –

    Can we expect further Scrivener-specific MMD documentation coming from Fletcher before the 1.0 release?


    Sorry, I don’t know. This is really up to Fletcher, and he hasn’t been around here for a while. :frowning:

    Thank you very much. I do appreciate this, because I can not see how to use all the possibile options. In the moment I just export to latex and then manually do the things I need.

    One remark. Europeans would be lucky if you provide an option to use the koma-script classes. They are enhanced for the DIN formats, we use here. There are also several improvements in the koma-script classes to the normal latex-classes, so perhaps they can even be useful, when do not use DIN formats. It is possible to use other page formats. I never heard of the class memoir before, I must confess. :wink:

    One more: Any Latex expert can use the mmd-export, but for beginners it would be good, if you would include the babel package into the source, because non-ascii letters do not work directly with mmd-latex-files.

    Thanks a lot I like mmd very much!

    Have you tried switching your language to German in Scrivener’s preferences (under Typography)? The distribution of MMD included with Scrivener has around a dozen different languages supported. I am not sure if this is similar to what Babel offers, but to me this seems an awfully beginner friendly way of exporting.

    On Memoir: It is an excellent class that combines a lot of functions from other classes, expanding on the default book class. I am not sure how it compares to the koma-script ones, as I do not have a lot of experience with them. You might want to download the documentation for it (I link to the PDF in the Tips & Tricks forum), and see if it is something that would work for you. Since I’ve never needed it, I do not know if it supports DIN at all.