Multiple language spellcheck

This is technically a follow-on to this post

I have a character who is natively bilingual French/English. Because this story is aimed at the English speaking market, the text surrounding her interactions is in English, and generally her conversations with others is in English. Her internal dialogue, however, will be French, English (or sometimes Franglais), depending on context.

The problem I’m having is I don’t understand how “automatic by language” determines when English stops and French starts. For example:

(Nan has just received a text message from a doctor, one she doesn’t know, and wasn’t expecting)

Their was no response from her subconscious, or her sister, which she noted were the same thing. But then her sister joked, peut-être il s’agit d’un psychologue? Ceux qui traitent de culpabilité de la survivante?

The two problems are

  1. How can I convince auto-correct to leave the French alone, and
  2. Why doesn’t “automatic by language” (which is set in both the system prefs and in the app’s Spelling and Grammar dialog) identify the French as correctly spelled?

thank you for any help!


I’m fairly certain the automatic-by-language settings is by paragraph, not by clause. Since this is a chunk of Apple code that is in a black box, I am not sure what all logic goes into their attempt at detecting the language and marking the text accordingly. It’s probably bewilderingly complicated, and in my experience from reports over the years, it is not without its bugs—sometimes to the extent of causing spell check to malfunction completely even with a single-language text.

Sorry for my lack of experience with this. I’m monolingual so I do not have much by way of practical experience with the feature, but I saw nobody else had responded.

Thanks for that comment “automatic-by-language settings is by paragraph”.

I am working in two languages, and I found that if I pasted the same Spanish text into two different paragraphs, it would show up with “red-underlinies” in one paragraph and with Spanish spell-checking in the other. If I inserted a carriage-return into the first paragraph so that there was no English in it, the red-underlinies magically went away.

The strange thing is that it is not true that “automatic-by-language settings is by paragraph”. It is possible to combine two languages in the same paragraph and it “just works”, but sometimes it “just doesn’t work” too. When it doesn’t work, you can fix it by inserting a carriage return (at least so far, on my computer).

Would I prefer a language setting, like LibreOffice and Nisus Writer have? I think so, but if this is the built-in solution, I can see why Scrivener uses it.