Multiple lines allowed in document titles

Hello Keith,

First thank you so much for the wonderful software. I’m definitely going to buy it! :smiley:

I hope this is not a duplicate bug report, but I didn’t find anything about that while searching for “new line”. In fact, maybe it’s a desired behaviour. It just got me puzzled at first, when I cut an entire line (unwillingly including the ending new line character) from Pages and pasted it into the document’s title within the Binder tree. It simply appeared as if it didn’t work : the box “appeared” empty. So I repeated the operation over and over again. Until I figured it out. It was working, but the undesired new line character made it so that a second empty line was displayed in the text box, while my desired text was hidden right above. I could however scroll through the multiple lines that I had pasted by using the up and down keys.

I also tested using the Option-Return key combination and was able to add additional lines at will. I think that multiple lines in a document title are not useful and are at best very confusing, especially since the only way to see those extra lines is with the up/down keys while editing. They are not displayed anywhere else.

I am not sure exactly what the correct behavior should be, but I think that Option-Return should at least be disabled within the text box. Trimming the clipboard content at the first new line character would also work. I read somewhere on the forum that multiple lines should be concatenated with joining spaces, but I disagree, in the context of document titles that is.

Steps to reproduce :

  1. In a word processor such as Pages, triple click on a title (a paragraph with a single line) to select it completely including the ending new-line character and press Cmd-C.
  2. Create a new document in the Binder tree by selecting any existing document and pressing Return.
  3. In the title text box that automatically becomes in edit mode, press Cmd-V.

Actual result: an “apparently” empty text box, but pressing the Up key reveals the pasted line. Have to press Delete once to remove the undesired new line character and reveal the real text.

Expected result: my text in the title text block, with the new-line character stripped out.

Hope this report can be of any help…

Thanks again for that great piece of software! Being a programmer myself, I can appreciate all the little details and the efforts you put into it. Keep up the good work!

Warm regards from Montréal, Québec, Canada,



Many thanks for the kind words, much appreciated!

This isn’t really a bug though. Although you are right that in most cases it’s not useful, there are those who for whatever strange reason do like to add extra lines to the titles, for export reasons, even though you can’t see them and they aren’t really useful in Scrivener.

Hmm, I don’t really know. For me, I agree with you and would be happy to restrict it; and certainly in Scrivener 2.0 you can add prefixes and suffixes and extra lines to titles on the fly at compile time. It’s just that I have heard from users who do this. So, I’ll leave this one open to debate. What do other users think? Should the title area prevent you from entering more than one line altogether?



As a programmer, the way I usually resolve that kind of issue, where both behaviours are useful to different kinds of users, but one scenario is more likely for most users, is to add an option in the Preferences. In that case, since most people aren’t even aware of the possibility of having multiple lines in document titles and would be confused as I were if they pasted a title with a new line character at the end, I would make the default value “Allow multiple lines in document title = disabled”. Then, those who do use and appreciate that possibility would not feel frustrated as they could re-enable it at will.

Just for brainstorming sake, here are the possibilities I see :

  1. A checkbox in Preferences : “Allow multiple lines in document title” (if unchecked, only first line is considered)

  2. A dropdown in Preferences : “Behaviour when pasting multiple lines in document title” with the following options : “Use only first line”, “Merge into single line with spaces”, “Preserve individual lines as-is”, etc…

  3. (Which can be used in conjunction with #2) A pop-up that is displayed the first time multiple lines are pasted in a document title, prompting for the behaviour to use (with same options as #2) and with a checkbox “Always use that behaviour”.

  4. A pop-up warning message that is displayed the first time multiple lines are pasted, warning the user about what is involved when pasting multiple-lines in a document title, with a check-box “Do not show this again”.

Please note that these are just suggestions and the wording and actual options are just off the top of my head. I think that whatever is done about that issue, something has to be done, to avoid confusion for all present and future users. I personaly won’t be bothered with that issue anymore, as I am now aware of the quirk. I offer those suggestions solely for other people’s enjoyment and for improving the clarity of the software in that regard.

I know this all requires work, among all the other things that need to be developed, so Keith feel free to do whatever you think is best for your software and workload! :wink:

Sincere regards,

The trouble with preferences is that there are already a lot. :slight_smile: And in this case, if there are already multiple lines in the preferences, then if you turn this option off, either Scrivener has to delete those multiple lines (perhaps checking with the user) or the preference doesn’t match what is already there. This is the sort of thing I think should either be restricted or not, without any preference. And I tend to think that if you paste a big chunk of test in the title then it is - usually - an intentional action. But I will certainly listen to what other users have to say (thanks for your input Andreas).

Thanks and all the best,

That’s why I suggested #4, a simple pop-up message to warn the user about that is really happening. It requires no extra settings in Preferences and cannot have a mismatch with what’s already there. It’s just a warning and users who do want to use that as a feature can simply turn it off.

But as I said, I’m not even suggesting that feature for my own usage, just to help new users, so let’s see what everybody thinks! :wink: