My paragraphs have extra space between them in 2.9.0.11 I can't get rid of

I have tried to set the spacing before and after paragraphs to 0 (and other values) and changed line spacing multiple times to all different settings I can think of but my paragraphs keep having extra space between them. I tried googling and I think I know how it should work but it doesn’t for me.

I didn’t have that space in earlier beta version.

Is there something I can try to do or do I just wait for an update? I’m not an expert with Scrivener so I guess there is a possibility that I’m just not considering some setting.

I converted my documents to default formatting and this seemed to fix the issue for now. I still think there is a bug buried in this.

Edit:
The problem comes back if I try to change the line spacing to anything other than 1.

Same here. Even though I have my spacing “before / after paragraph” both set to 0.00pt.

Another one here with the same problem. I think I saw this on the previous beta version too.

Guys, just to let you know that the line spacing is a known issue and we are doing our best to fix it sooner than later.