MyScript Stylus and the missing 8 capitals

I have been using MyScript Stylus in Windows 8/MSWord2013 for a year or so - very good handwriting recognition and a nice alternative to the keyboard (now and again for me) - I use a Huion tablet. So I thought I’d give it a go in Scrivener. It works well in the fullscreen editor though the switch between pen and pointer mode is sometimes a bit clunky. However something strange happens in the standard editor window of Scrivener - eight uppercase letters refuse to render to the screen, not even a blank space. In Stylus you can switch on a virtual keyboard instead of using the pen. Same result - types all the lowercase characters perfectly, but press capslock (or use the shift key) and only 18 letters will work. Punctuation and numeral are fine. ACDGHPST are the refuseniks for what it’s worth. Tried two different computers with the same result. Works fine in the Scratchpad and in other apps. Suggestions welcome…

This looks identical to a clipboard problem we were seeing in the PhraseExpress text expander working with Scrivener, which appeared to be a conflict between PE and the version of the Qt framework that Scrivener is built on. In that case, expansions formatted as rich-text worked correctly, but the same capitals went missing from plaintext expansions. The latest update to PhraseExpress appears to have corrected this, although I don’t know what they changed specifically to address it.

Unfortunately I don’t have a workaround to suggest at the moment other than working in full screen or writing elsewhere and then copying into Scrivener afterward. I assume you’re using MyScript Stylus v3.2?

Thanks MM - it’s good to see that this is a recognisable issue even if there is no immediate fix. Yes I am using Stylus v3.2

… yes - happy to be working in Fullscreen. I will log the fault with MyScript together with your note about PhaseExpress. Thanks again for the prompt feedback!

Thanks, I’ll get that in the report. I was a little hasty with my comment about PhraseExpress, it looks like–some of the expansions that previously dropped caps are working now, but not all of them. So something must have changed in their latest update, but it hasn’t quite fixed this.

The next major version of Scrivener will have an updated Qt foundation, so if it is not resolved beforehand, that may fix the issue. Meanwhile I’m glad full screen is working for you!