Mystery bolding

I have two text documents. Each has a heading preset. The body text is regular and not bold. I export the two text documents to an epub. When I view the epub, all of the second text document is bold, even though only the heading is bold is Scrivener.

Any idea where this mystery bolding is coming from?

Also, the epub has a “Contents” section at the beginning. I didn’t add it. Anyone know how that is getting into the epub?

This (the bold issue) is exactly the problem I’m having over 8 years later! Does anyone know a solution? When I compile the same document as .docx, it’s fine, but in the epub, everything except front and end matter is bold. I do have a bold chapter title that I manually typed in at the beginning of each “chapter” document in the binder, but nothing else should be bold. In case it matters, the font is Garamond. Even when I highlight the text and click “preserve formatting”, it still compiles as bold. Can anyone help me solve this?

To take a wild guess, I would say that your epub ended up having bold as text attribute for the default text style in its stylesheet.
That could be easily seen/fixed in Sigil.

Perhaps (or probably, even) in Scrivener (if it ain’t what you already did) you should use a style for your titles, and let the section layout of your compile format handle the rest.

I am using a style for my titles. Surely there’s some way to see/fix the problem in Scrivener itself!

Sure. But that doesn’t really matter.
What matters is how the body text is treated in your compile format.
Something is probably making your title’s attributes to be rendered as the default text attribute.

Can you post a screenshot of your section layouts ?

Another explanation, if you also styled your body text, could be an invalid style name.
Perhaps causing the epub to stick to your title’s attributes, unable to access the body ones in the epub’s stylesheet.

First thing I would do in your shoes, would be to compile a single chapter, without its title, and see.

Question: are you using the same compile format when compiling to docx ?

I tried deleting the title of chapter 1, highlighting the whole chapter in the editor and making doubly sure it was all unbolded, then compiling just that as an epub. It still shows up as bold in the Books app. And yes, as far as I can see, I have everything set up the same way in the section layouts when I compile to docx.

I use no style for the bodies of the chapters; only for the titles and some other info that comes at the beginning of each chapter (a little image, the name of the character whose POV it’s from, and in some cases the location and date of the setting - but out of all that, only the chapter title is in bold).

Here’s a screenshot of my epub section layouts. Thank you so much for taking the time to look at this and help!

Proceeding by elimination :

  1. Screenshot of your CSS pane please. (On second thought : if the demo text is bold in there, don’t bother with a screenshot, just fix it, as this would 100% be your issue :wink: )

  2. What if you change your font to a more standard Times New Roman ?

  3. Are you certain your chapters are assigned to the “chapter” section type ?
    (In the project, I mean. Metadata pane.)

  4. Could you repeat the single chapter compile to epub (replacing your body text with gibberish) and post the resulting epub here ? (I’d have a look in Sigil.)

You can usually use precisely the same format and layouts for both with no changes. Are you?

We can do a zoom session if you want.

Zoom me

I double-checked, and yes, the formatting for the docx and epub are identical.

Thank you. I may take you up on that if nothing else works.

I compiled it, but I can’t seem to upload it here as an attachment. It only gives me the option to attach jpg, png, or docx files. Any thoughts on other options for getting it to you?
Thank you so much for being willing to take a look!

Post a Dropbox link to it. Better yet, to a zip backup.

Not that the solution will necessarily come from me, but here is what I found looking at your chapter in Sigil :

removing bold from your title style made all the following text become regular :

image

image
. . . . . . . . .

.ps1 is the paragraph formatting Scrivener assigned your body text :

To which adding → font-weight: normal; ← fixes the issue

image

So it is like I said earlier : something is making your title attribute stick throughout the body text.
As of why your epub ends up compiled like that though, I have no idea at the moment.

. . . . . .

[EDIT] Just skip what follows and go straight to AmberV’s post. She’s the best of the best.

. . . . . .
Do you have this option checked ?

From your earlier screenshot (Section layouts pane) :
image
. . . . . . . . . . . . .

In the main compile panel, middle section, does your text (the demo text for the layout) look the way it should for the “chapter” section type ?
Or is it bold in there too ?

image
. . . . . . .

Try adding this to your CSS stylesheet :
.ps1 {font-weight: normal;}

1 Like

Before getting too deep into this, just to confirm, you are posting in a macOS thread, and given that the Windows ebook compile implementation is still a work in progress (they made it pretty much functional if you don’t touch many settings, but things get very thorny if you try deep customisation), and its output can be quite different from the Mac’s.

So it would be good to know what platform you’re compiling from, before going too deep into this. I think I might know what the problem is, based on what I’m seeing.

I didn’t ask if the formatting is the same. I asked if you’re using the same format, i.e. choosing the same format on the main Compile screen.

No, because I have separate formats set up for ebooks and paperbacks.

I’m using my Mac.

Where, exactly? At the top? Sorry, I’m one step away from illiterate when it comes to HTML! Here’s a screenshot of what I see in the CSS section of the compile menu:

And THANK YOU for taking the time to write such a detailed response, with the screenshots and everything!

BTW, I tried editing the style of the chapter titles so they weren’t bold, and sure enough, when I compiled, everything looked right after that (except, obviously, that the chapter titles are supposed to be bold). I have some bold text in the front matter, but apparently that wasn’t a problem. If all else fails, at least I know I could unbold the titles and make it work, but it would be great to be able to keep them bold …

The closer to the bottom you add something, the more “important” it gets, as it overrides everything that came before.
So if you are gonna try this, although it doesn’t seem like it could be related to anything you already have in there, might as well put it at the very bottom.
Double check for typos. It needs to be just as I typed it.

I copied and pasted to make sure I didn’t put in any typos. Alas, upon compiling to epub, everything is bold once again.

:man_shrugging:
With a bit of luck Amber or someone else will know.
I can’t think of anything else.
Just be patient.

Ok. In the meantime, I really appreciate all the time you put into trying to help me figure this out! At the very least, now we know a lot of things that are not causing the problem, along with what doesn’t work to fix it! Maybe someone with a similar issue will read this thread at some point and find a solution that does fix their problem.

1 Like