Narrow non-breaking space in recent upgrade

Hi :slight_smile: I really like the narrow non-breaking space that now gets automatically inserted with French guillemets (« »)
I would like to bring to your attention that, in French (French-Canadian the least), a non-breaking space (standard, not narrow this time) is also required before !, ?, : and ;.
Would be an awesome time saver if these could be implemented as well…

I know it can somewhat be done via replacement in the option panel, but it is buggy… (If you don’t hit space or enter right after typing !?: or ; but jump somewhere else in the text using the pointer, it doesn’t get inserted - which means it happens a lot on editing text that is already there…)
Thanks.