[NB] Missing Chapter Text Upon Opening Scrivener

Hi there,

As of the last two updates, when I open the program the page I last worked on is blank. :open_mouth: :confused:

After the first heart attack, I clicked on a different scene, then went back to the one I was working on during my last session and the text returned.

This continues to happen every time I close and then reopen the program. And yes, I am backing up my work on a very frequent basis.

Thanks for looking into this and hopefully solving it.

Does the text in that particular document fill up the entire document?

Asking because the screenshot shows the doc scrolled to the very bottom, and I was wondering if it’s a case of ‘the doc is being scrolled to the bottom, where there is no text’ vs. ‘the text is disappearing’.

Yes, it does fill up the entire document.

If possible upload the project with only a document or two. Hopefully I will be able to reproduce the problem. Looking at the screenshot only, will not help unfortunately. To trace this problem I need to reproduce and debug it locally. Thanks!

I’ve no idea how to upload here. Can you walk me through that, please?

Using Scrivener

  1. Create a new blank project.

  2. Drag & drop one or two binder items (scenes) from problem project to new project

  3. Confirm the issue is happening in the new project

  4. Create a zipped backup of the new project. File > Back up > Back up To > For Location: put it on your desktop; For Name: Call it ‘Example’; Make sure ‘Backup as Zip file’ is checked.

Using this message forum
5. Press ‘Post Reply’

  1. Press ‘Attachments’

  2. Press ‘Add files’

  3. Select ‘Example’ from your desktop and press open

  4. Press ‘Submit’

Where is the project stored? This is the behavior you might see if it were stored in a OneDrive volume, with “smart sync” turned on so that the files aren’t actually downloaded until opened.

Katherine

It is behaving properly now. Not sure what that was about.

I created a test document, and neither that nor the original have that problem now.

Unfortunately, when I open Scrivener to begin work, after the announcement comes up, I click OK and this happens (see attached).

Is that supposed to happen now?



Most likely you have enabled logging via File > Options > General > Show internal log console.

Yep, I sure did. Not sure why I did that. Ugh. I’m sorry to have bothered you all with such minor (and stupid on my part) issues. You have enough on your plate without stuff like this added to it.

Thank you for all of your hard work to produce such an amazing product.