New Beta 1.4

@LAP indicated that the new Linux Beta is on the way… will package for Ubuntu (etc…) once I see it, so wait for my .deb to make it an easy upgrade!!

Well, it’s here:
http://www.literatureandlatte.com/forum/viewtopic.php?f=33&t=10649&start=0
Any chance you could perform your .deb magic, please? :slight_smile:

hehe, new baby to play with…

ANYWAY, I apologize (with a little baby spit-up on my shoulder)!

Here we go, with ‘all’ arch for amd64 guys (we’ll see how this goes)

should be an easy upgrade for everyone,

$ sudo dpkg -i scrivener-beta_1.4beta-6_all.deb

Ubuntu

Slackware

If Dropbox won’t let you get it, I’ve probably been locked out, even though there’s a 10GB daily transfer limit. If that happens, they are also here: On my Webserver

Excellent. Works a treat on Ubuntu Maverick.

Thanks for the deb Randy, and thanks to the L&L team (particularly Lee!) for the superb software - brilliant stuff.

Awesome, thanks! Just in case anyone else is having this problem, I got the following in the terminal when I first upgraded and tried to run Scrivener:

could not read from search indexes file return links 0 QMap() LiteratureAndLatte/bin/Scrivener: symbol lookup error: LiteratureAndLatte/bin/Scrivener: undefined symbol: _ZN14QTextRtfWriterC1EP9QIODevice
Turned out I’d left an earlier Scrivener beta in usr/local/LiteratureAndLatte before I started using randywallace’s .deb packages. I removed that, then removed and reinstalled the .deb package, and everything works fine now.

Coral CDN cache links of all the above to help spread the load.

Ubuntu:
dl.dropbox.com.nyud.net/u/623040 … -6_all.deb

Slackware:
dl.dropbox.com.nyud.net/u/623040 … .4beta.tgz

(You append .nyud.net to the hostname, if you’re unfamiliar with it.)

Randy, if it’s smacking you that hard, let me know and I’ll gladly help share the load, whether through my own dropbox, or we could set up a torrent, or my own server.

I’m a debian user and the deb package worked like charm. However, a friend of mine is a Fedora user. So, I had built a rpm package with alien.

How-to

sudo alien -r scrivener-beta-1.4beta.tgz -v --generate sudo rpmbuild --buildroot=/home/ro/scrivener-beta-1.4 -bb --target i686 scrivener-beta-1.4-2.spec

dl.dropbox.com/u/1031391/scriven … 4.i686.rpm

Thank you RandyWallace - the deb magic worked perfectly.

Oddly enough I haven’t been able to get the .deb to work. It installs, but won’t load. I just copy the contents of the tar over to /usr/local and that works fine.

The single progress I see in this Beta 1.4 is the lack of that annoying progress bar of the words count…

I installed using the .deb thingy and it acted like it would work until I tried to open a scrivener project or start a new one, then it just went away. I tried copying the files to the \usr\local place, and now it just goes away after the beta version info box. So then I reinstalled with .deb, and it still just goes away. Any help for those of us who have to look everything that has to do with command line stuff?

Thanks! Using Ubuntu Netbook Remix 10.10

@faithy666 - when you copied the LIteratureandLatte folder to /usr/local/ did you navigate to the LiteratureandLatte/bin directory and type “ldd Scrivener”?

Have a look at this: davidlday.com/tag/ubuntu/

Also, have you tried the new beta 1.5?

faithy666, you said it goes away…what happens when you launch it from terminal? is there any kind of error reported?

I’m not sure what I did wrong to begin with, but you guys set me on the right track. I ran the .deb file, and apparently it didn’t take, or maybe I needed to delete the old Scrivener files. Either way, it seems it was an amalgam of old Scrivener and new, and there was a LiteratureAndLatte folder inside the LiteratureAndLatte folder (perhaps I did that when I tried de-archiving the files). So I moved the new folder, the inner LiteratureAndLatte folder, out and overwrote the old one with it. My problem-solving skills are always better on day two. :slight_smile: And now it works, which is good, and I am happy.

When the this beta expires, do I need to delete the old Scrivener before adding the new one?

Thanks!

That’s what I’ve been doing. Of course, make sure your project files are not in the LiteratureandLatte directory. Only problem with deleting and installing new betas is that the project menu (i.e. recent items) is wiped each time and has to be redone.

In my Windows version I just reinstall the new beta over the top of the old, though it’s recommended the old one is completely uninstalled first. I haven’t noticed any problems.

For what it’s worth, I always use the uninstall program to clean up the WINE one and delete the folder from /usr/local before untaring the new one.

Never trusted the uninstall, I use shift-delete and regedit. Also shift-delete on the native Linux build.

P.S. just found that amd64 users need to apt-get install only ia32-libs and ia32-libs-gtk
Maybe somebody could post this on that wiki-like page for LInux users :slight_smile: