New document text just types write off the edge of the page

Whenever I open a new document, I’ll start typing and as I hit the point where it should automatically wrap into the second line, the text just continues going clean off the side of the page. It’s still there. All I have to do is save the project, close it, then immediately reopen it and all the text is properly formatted and wrapped like it should and the problem disappears. But it’s quite annoying (and a bit time consuming when you’re project’s got over 300+ MBs of research data contained in it) to have to close and open the project overtime you start a new scene. Just wondering if anyone else has had this problem.

Here’s the before picture:

And here’s what it looks like after:

I can’t think of how this would happen, but it might just be a simple preference problem—maybe your default formatting settings have some odd setting within them that isn’t anticipated by the text engine. I’d try resetting those to see if that solves the problem, using the Formatting preference pane. Note there is a button at the top of that panel to use the settings you left your cursor in—so try doing this from a file that has already been “fixed” by reloading, or if that doesn’t work I would try this:

  1. In Preferences, use the “Manage” button to save your settings to a preset.
  2. Use the “Defaults” button to reset the software to factory default.
  3. Create a new blank project and type in a couple of words using its default formatting.
  4. Use the “Manage” button to revert back to your settings, and use the paragraph in the blank project as a basis for the Formatting pane, changing things as needed (TNR instead of Cochin, etc.).

Additionally, I noticed you have a right-indent marker at about 6“ (which seems to be ignored in the first screenshot for whatever elusive reason). You wouldn’t generally want to set a right-indent on every single paragraph like that, so I was wondering if you’re just looking for a way to keep text from going ultra-wide on your screen? If so, check out the ”fixed width“ options in the Editor preference pane. That will keep your line-width from going crazy without actually having to insert formatting into the text (something that may be problematic down the road—for example this 6” right-indent may very well end up being 7").

I think that got it. I probably should have mentioned I brought this particular preference over from the Windows version which is what I started on. I read somewhere they were supposed to be cross-compatible. I guess this was a bug.

Thank you for taking the time to reply to my question.