New forum member - Basic question, formatting frustration!!

Ok, I know this is probably an easy question but it’s frustrating (simple things usually are, right)!

So I writing in the document view, Mac. I indent the next line for some dialog, and want the next line to return to the left margin. I hit return, and it defaults to the same indented line, and I can’t see how easily to override it.

I wish to indent the dialog frequently but keep everything else left justified…


One of the moderators has a useful post outlining how Scrivener files are impacted by different formatting options…

Scrivener is a writing studio, not a WYSIWYG word processor. The final formatting is usually controlled at the compile stage, or post-compile in a suitable design program if necessary…

Are you using the tab key to indent your paragraphs? I recommend not using the tab key, especially if you are going to output your work to another format or will be submitting it to a publisher. Better to use typographical indentations (through the ruler—though that’s a chore if you need to deviate from the file’s default settings repeatedly), as tabs don’t translate well…let alone using multiple spaces to simulate indentations.

If you do want to use the tab key, you just need to set your documents up using the advice given in the first link. For an existing file, you can select all the text and adjust the ruler to remove the first line indent (if that is currently the default). Your existing tabs should retain their positions.

Press CMD R to toggle the ruler on and off.

Thanks Briar for the tips.

Main thing is after I indent with the spacebar and type my text, followed by a Return, the cursor tabs into line with my indented text. I don’t want that. I know when I compile it I can do formatting changes, but in the meantime it’s a needless distraction…
Certainly don’t want to monkey with the formatting bar every time, just eliminate auto format attempt.
I want to compile as close to an Editor-ready document as possible.

(In a rush, so quick comments only…)

  1. Create a new document inside Scrivener (cmd-N).

  2. Type a paragraph in the document and format it EXACTLY how you want all your paragraphs to look in future. Use the Ruler and Formatting bar and the command on the Format > Text menu to get it spot on with regard to font, linespacing, indentation (first line, hanging and whole paragraph) and spacing before and after the paragraph.

  3. While you have that document in focus, go to Scrivener > Preferences > Formatting and click the Use Formatting in Current Editor button in the top right corner. You’ll see the dummy text in the Editor preview change to your new style.

From then on, every document you create in this or any other project will open with this default formatting. (You can change individual paragraphs within a document and those change will persist for the rest of the document unless you change them, but they will revert to the default with new documents.)

Don’t try to indent your default paragraph with spaces / tabs – if you want first line indents, build them into the default.

You can convert existing documents to your new default format by selecting them in the binder and choosing Documents > Convert > Convert Formatting to Default Text Style.

Sorry for the rush, but if you follow this procedure, your problem with the odd paragraphing shouldn’t occur…Hope it’s enough to get you started.


Selecting the entire text and moving the indent marker on the ruler (CMD R) should do what you want. Like this…