New install is not in English

I installed Scrivener 3 on my laptop all fine. When installing on my desktop it all installs with English agreements etc, then defaults to another language.

When I navigate to the language section in settings and choose English and re-start nothing happens.

Any idea why this may be happening?

Currently, 3.0 may first run using your system language, if Scrivener has a volunteer-provided translation package for that language. The intent was to only have this run automatically if the interface was fully translated for the given language, but there seems to have been a mix-up so that that some of the “Preview” language are nevertheless being used. We’ve corrected that for the next update, but it does mean that currently you may need to explicitly set the language to English after opening or creating a project, going to File > Options and under the General tab, selecting Language and then choosing English from the dropdown list and restarting Scrivener.

Now, in this case–clearly there’s something else bizarre going on; it looks like the interface is using English but with some of the letters being swapped with others. What is your default Windows system language and region? Which version of Windows are you running?

One thing to try is deleting all the translation files, in case they are playing some part in this. With Scrivener closed, open its installation folder and move the “translations” folder to another location (e.g. to the Desktop, just temporarily to see if this affects reloading the interface). Then launch Scrivener again–any better?