New install unusable

I have just installed from Arch repository and so many things are not working that I find it to be unusable.

I worked through the included tutorial, the spacewalk pdf file opens as a blank document, 4 pages of nothing, I can open the pdf manual ok from F! or new project/getting started. The media file ‘thisisbuzzaldrin’ crashes the programme if I try to open it.

These 2 items, and the spell check that does not work yet (though I only think I have all the files needed for it to work,) are not so important for me. I could work just as well without them and never use them.

My biggest problem is importing files, basically I can not. Any attempt to import anything produces a crash to desktop. I converted my novel to text and to rtf from Libreoffice, if I try to import through the menu I get a warning that files are converted to rtf then the ctd when I click ok. If I try drag and drop of either file then I get an immediate ctd. If I right click on a folder and select add file it sometimes displays the warning but still ctd. The crash occurs with any type of import text, jpg or media files and wether I am importing into Draft or Research folders.

It is impossible to see the contents of pdf. They are easely opened in external viewer. I installed a windows-version and used it uner PlayOnLinux. Windows version doesn’t show pdf’s.

The crash on importing files sounds like the qt library problem. If you run Scrivener from a terminal you should see the error message when it crashes: is it something like “Cannot mix incompatible qt libraries”? There are several threads on the forum about that. The only thing that fixed it for me was changing Linux distributions, but you might find some helpful ideas; you may need to check you are running Scrivener via the provided script and not running the executable directly.

I was able to get the spellcheck working by installing libaspell-dev (on Linux Mint).

runnning from cli I get this when I try to import

code: GLib-ERROR **: gmem.c:421: overflow allocating 1852785409*4 bytes
/usr/bin/scrivener: line 6: 4927 Trace/breakpoint trap (core dumped) LD_LIBRARY_PATH=/opt/scrivener/lib /opt/scrivener/bin/Scrivener
/usr/bin/scrivener: line 7: EOF: command not found[/code]
Not sure if that was what you meant, I’ll look into the other threads you mention.

The destop file exec points to /usr/bin/scrivener which is a short script


#unsetting this variable seems to be needed to keep from using incompatible Arch QT libs

LD_LIBRARY_PATH=/opt/scrivener/lib /opt/scrivener/bin/Scrivener

/opt/scrivener/bin/ contains Scrivener executable and script, are you saying the script above should point to the script file and not the executable? I did try changing it but still get the crash to desktop.

That’s a different error message from the one I got on Ubuntu 12.10 with the same behaviour.

It looks as though the startup script (which is supposed to be a workaround for the Qt library issue) is getting called, so that isn’t the problem.