New Laptop/Username - Can't Save Files Anymore

Hello -

I’ve tried searching the forums but didn’t find an answer for this, forgive me if I missed something!

I bought a new laptop, and used the Mac migration assistant to copy everything from my macbook pro to my macbook air. Once on the Air, I realized I wanted to use a new Username so I copied my material from the automatically-created username from my old laptop, to a new Username.

The only problem is, now when I open Scrivener it tells me it can’t save (“There was a problem saving the Project”), and thus I can’t use it. I assumed I just needed to show it where the save folder is now located, but I can’t seem to find any way to tell the software to save materials to a new subfolder or directory.

Does anyone out there have any ideas? I’ve been writing in Microsoft Word for the past few weeks while I tried to figure this out, and to be honest Word is killing me. I need my Scrivener back! :slight_smile:

Thank you!!

If you haven’t already, I’d suggest de-installing Scrivener and re-installing it under the new username. Reason being that the old username’s installation probably doesn’t have permission to write in the new username’s file area.

Katherine

It may be a rights issue. See the following…

https://forum.literatureandlatte.com/t/problems-saving-projects/26287/4

https://forum.literatureandlatte.com/t/cannot-transfer-work-to-new-computer/24516/7

https://forum.literatureandlatte.com/t/scrivener-wont-save-project/24879/1

Hope that helps.

Thanks everyone for your swift help - I appreciate it!

I’ve figured out part of the problem, I think, but still can’t get old projects to open.

Here’s what I did:

  1. Un-Installed and Re-Installed Scrivener onto the user account I want it on.
  2. Paid for the upgrade, which I hadn’t done yet, and used that registration key upon starting up the program.
  3. Then I used the procedure described by AmberV in one of those forum links, where I open the scrivener file’s info window,turn it into a folder, change permissions, apply to enclosed, and change it back to a .scriv file.
  4. When trying to open that file (with permissions fixed), I get an “Update Project?” dialogue box due to the new version. But when I click “update” I get a new dialogue box: “The Document ‘name.scriv’ could not be opened.”

The good news is, I’ve got Scrivener up and running (yay, and thank you!), but now I just need to figure out how to open old project files. I will search the forums this weekend, but if anyone has any thoughts please let me know.

Thanks!

Ah. These are old project files.

The .scriv “file” is actually a folder, containing potentially hundreds of files. It just appears as a single file because of how the Mac presents such “packages.” So one thing to check is to make sure that the entire folder transferred from your old system. In Finder, right-click and choose the option to “Show Package Contents.” You should (for a Scrivener version 1.x project) see among other things a bunch of .rtfd files, maybe some synopsis.txt files, and a file called binder.scrivproj. Is that what you have?

Katherine

Hi Katherine -

I’ve done for a few of my project files, and I definitely see 15 - 20 files like the ones you mentioned (.rtfd, binder.scrivproj, html, and some synopsis and quick look files).

Just out of curiosity, can these projects be opened in Scrivener 1.54 (you can download it off of the support page in the blue sidebar, and it will run okay on a modern Mac for a simple test like this). If the projects themselves have problems of an unknown nature, then it would explain why the updater is failing. You could try creating a new blank project in Scrivener 2.5, and using the File/Import/Scrivener Project… to select the old one you’re trying to update, and import it instead. This often works when other problems cause the update to fail.