New to the Scrivener World

Hi, all!

Many XXXXOOOOs to the LaL people for making this product available. Since I heard about it through NaNoWriMo last fall, I got curious and downloaded it. Recently I installed (beta version 0.1.9) and tried it.

I’ve found the occasional bug. Some I’d found have been fixed in beta 0.2.3) such as the coloration issue for footnotes and annotations. I am delighted (I actually wrote a blog post about how happy you’ve made me), and I have very little “bad” to note here. Just some observations…

I have the beta downloaded and installed on two machines (a laptop running Windows 2003 server; a desktop with Windows 7 ultimate) and have experienced different reactions (obviously) on both. Both have Microsoft Office installed (Office 2007 on the LT; Office 2010 on the DT)

Issues I found on the laptop:
Tried the “Compiling the Draft” section of the Tutorial: Got an error: {The specified module could not be found: WKLS31.DLL} Looks like it was a Word error by the icon chosen… PDF still created. Flashed another notice, a printing page message

Undo from a Merge – couldn’t do it (at Step 16 in the Tutorial I tried merging several pages… It merged, but when I wanted to go back to what I’d had, it blanked out the page and deleted the text from the document created as well as deleting the merged document–glad I created a PDF of the Tutorial via the Compile feature so I still had something to refer to).

Desktop:
Pasting text from the Windows clipboard only worked as a straight CTRL-V paste, no other formatting style (either in keyboard shortcut or drop-down) worked

Both versions:
Crashed when moving from Full Screen to Multi-document

Default for program install should probably be “Program Files” not “My Documents”

The beta pop-up upon opening the program did not reset between installing (despite my uninstalling the previous versions) 0.2.2 and 0.2.3 so it keeps telling me that my evaluation will expire on the 15th as opposed to the 30th as noted on the website.


Other than that, I’m really tickled with the product. In all that free time you have, here’s my dream list of features I’d like to see:
– a good way to make user “dictionaries” or ways to allow privileged speech of some kind that can be used in more than one project.
– I’d also love a way to export a section of a main project into another Scrivener project.

And I’m curious about the Name Generator (a feature I love just because I love that “sort of thing”)… What reference was used for this list? I always thought Russian–Pavel–was a diminutive of Paul, not “Little”.

Again, MANY MANY thanks for this product.

Warmest regards,

Hello Eden,

Welcome to the Scrivener World. Hope you have fun with it as well as finding it useful.

Merging problem: what method did you use to “undo” this? Merge by itself has no undo because it requires a long sequence of actions internally to combine potentially up to eight or more files (many of these are hidden to you, but they store things like notes, synopsis, etc). Peeling all of that back apart into the original format would not be possible. So the preferred way to “undo” a Merge is to use its opposing feature, Split.

If you encountered bugs with split, it’s probably a separate issue from Merge, as by that point the program has forgotten these were ever more than one file.

Expiration date: Mine states the 15th as well. I’m not sure which is accurate, that or the web site.

Install location: should definitely be Program Files. Did you get “My Documents” right out of the box? If so have you installed programs there in the past? Perhaps Windows or BitRock (the installer software) remembered a prior override and provided it as a default for you.

Easiest way to do that is to open both projects at once and drag and drop the resources from one binder to another. This preserves most meta-data, and is so useful a lot of people keep an “ideas” project from which they drag out ideas that have grown into projects.

Pavel is from Latin, which means small or humble. It is also, as you point out, a form of Paul or Paulus.

Does this mean you were using Scrivenings mode in full screen, and it crashed when you exited full screen?

Anyway, welcome to the club!

I’ll have to double-check, but I believe that this is how Windows Scrivener is currently defaulting for users without administrator rights–e.g. when I tried installing on Win7 from a regular user account, it defaulted to install in Documents, although I was able to change the location to Program Files. I’ve seen some others say they get this on XP, etc. even when they have admin rights, so it may be related also to the OS, since I know Win7 changed how some of that works.

So question here for EdenMouseMabee, did you get “My Documents” as the default install location on both computers, and were you installing from an administrator account?

And as Ioa said, welcome to Scrivener!

Hi back to everyone! :smiley:

I have full administrator rights to both machines, but only the Windows 7 machine gave me a default for “My Documents”. You may be right about the OS being the issue. I didn’t see the comment while looking through the forums before, so I’m sorry for repeating old news.

As for what AmberV noted about the merge feature, perhaps I should have used the Split to “undo”. The actual thing I wanted to “undo” though was the whole merged page disappearing when I tried editing a word that had gotten chopped in the process (I selected something halfway through a word), but a made a typo, had the spellchecker “fix” it, but my bad touchpad control made me select the wrong word, so I “undid” that… and THAT is when I lost things.

(almost as convoluted as the merging process is on its own, I’m afraid)

Other than that, I really do love the program and have my payment ready; Scrivener is that tool I never knew how much I needed until I tried it. Now… if you guys suddenly decided to stop the Windows version production, I’d be down to the Apple store tomorrow afternoon.

Oops, sorry, didn’t answer this from AmberV:

Yes, but I cannot repeat the error on the Win7 machine. I’ve had it happen twice on the Win2003 machine (and not have it happen once as well), but only tried three times. I don’t know if you guys get anything from those error reports that get sent to Microsoft, but we did send one out.

As bugs go, it seems pretty minor (easy to work around) and on an operating system that I doubt many use, but just in case, I figured I’d point it out. It doesn’t affect my use of the program.

I wonder if Windows 2003 might be part of the problem here with a few of these. This version is, as far as I know, unsupported. Windows XP, Vista, and 7 are the platforms we test builds on. I am not terribly familiar with it, though, is it based on XP or the Win2k line? It might not work very well if it is the latter.

Windows 2003 and XP are essentially the same codebase – 2003 is the server side, XP is the client side. There are some minor differences, but generally nothing that should affect Scrivener.