New typing lags?

Is anyone else experiencing slight input problems with the latest betas? For me, it has been occurring with betas 9363 and 9464, and I’m just downloading 9486, so I’ll check on that.

It seems to happen when I pause very slightly, and also, I get the feeling, when I highlight and delete or cut some text. The first subsequent keystrokes don’t seem to register and nothing happens, then when I retype those keystrokes, the result is printed to screen twice, as if they have registered but the combination of cutting to buffer, deleting, or the automatic save is interfering with the print-to-screen routine.

When I’ve installed 9486, I’ll do further, more controlled checks, and see if it happens on my MBP as well, but I thought I’d post here to see if anyone else has noticed this. It’s always possible it’s something going on on my MBA …

This is on my late 2010 new-model MBA 13", 1.86 GHz, 2GB, 256GB SSHD with over 223GB free space. Other factors that changed round about the same time as this started are: Dropbox is no longer blocked here in LoTGFW (Yay! — but my project is not writing to that … I haven’t got that set up to work with this MBA yet); an update to DevonThink Pro, as yet unused; the Apple system-update to Java; and a new iPhone configuration utility from Apple, as yet unused.

Thanks
Mark

There have been no changes that should have any effect on input in these builds, as you can see from the release notes. One thing you could try is looking at the new log file Scrivener creates when an error is generated instead of writing to the console:

~/Library/Application Support/Scrivener/Logs

If there are lot of messages there (other than ones saying “call main doc”, which are intended to be there), then let me know. If something on your machine is causing extra logs to get written there, then the pause might be caused by the time it takes to write that file, especially if you have had Scrivener open for a long time so that the file has grown large. (The external log file is a temporary measure intended to help me find some outstanding bugs.)

However, that only started with the latest beta, so if you were experiencing the problem on 9363, this is unlikely to be the cause. Do you have any input managers? That would be a more likely cause.

All the best,
Keith

Hi Keith,

Thanks. Firstly, no, I don’t have any input managers as such, and nothing that has changed on the autoload list as far as I know, unless DevonThink Sorter has been upgraded or EvernoteHelper that will affect it.

The Scrivener Log is empty. The main console log has entries pertaining to OmniWeb using a deprecated method for something …; for Skype not being able to set up a system-wide password, though why should it — it’s very annoying, Skype having resolved their differences with China Telecom now only lets me access their pages on Tom.com here in China, which is worse than useless as Tom.com doesn’t seem to know that Macs exist, so although I can update through the app itself, I can’t get any change-logs — there has been a recent update, but that was since I posted; and some pertaining to GyazMail … I think in connection with a mail in html format with a lot of graphics that aren’t drawing properly … that’s today.

In other terms, I’ve updated to Scrivener 2.05 and also just updated to 10.6.7, so I’ll keep an eye on what’s happening. I’ll assume it’s something on my MBA unless anyone else comes up with a similar experience.

Mark

Hi Mark,

The only other thing I can think of is that some users have reported a typing lag since 2.0, but I’ve never been able to find the exact cause - it’s one of my ongoing investigations. There must be something on the system, either an external application or a file created by Scrivener, which is causing the lag, but I haven’t been able to find the cause. To that end, here are a couple of things to try:

  1. Quit Scrivener.
  2. Delete all preference files pertaining to Scrivener - that is, all files starting “com.literatureandatte.scrivener2…” in the ~/Library/Preferences folder (the next time you launch Scrivener, you will need to re-enter your serial number).
  3. Go to ~/Library/Application Support and rename the “Scrivener” folder to something like “ScrivenerOld” - anything other than “Scrivener” will ensure that Scrivener ignores it.
  4. Re-launch Scrivener and see if the typing lag persists. This will test to see if a corrupted preference file or support file is to blame.

If you still have a lag after the above, please try setting up a brand new user account on your machine and run Scrivener on it. If it runs fast again then there must be something on your primary account that is clashing somehow.

Also, does this affect all Scrivener projects? Are the affected projects stored on the local hard drive?

Thanks and all the best,
Keith

OK … I’ll do that as soon as I can. Far too much work at the moment, for the next week or so, but I won’t forget and I’ll get onto it as soon as the current load finishes … 90th Anniversary of the founding of the University, a couple of hundred VIP guests from all round the world, and all the offices and departments in the university are asking me to check the English of everything to do with the celebrations. My boss in the International Office has told the other departments that they’ll have to ask for help elsewhere as there is only one Mark … I told her she wasn’t quite correct, there’s only half a Mark, as the other half of Mark has to teach!

:slight_smile:

Mark

Ouch - good luck! And let me know when you get chance to test this, as I would really appreciate it.
Thanks and all the best,
Keith