New Update 3.1.5.1 has missing Menu Go To arrows for previous/next pages

I just updated to the latest Windows update (3.1.5.1) and the arrows in the Menu bar that take you to previous/next pages are missing. I can still access this function by going through the Navigate > Go To options in the top menu … but that takes up useless time when I’m adding research notes. It used to be so easy.

I’ve tried to roll back to 3.1.5 where it worked fine, but there is no download link available for that version in the Release Notes. ?

Not sure if this is the right place for this bug report, but I wondered if anyone else is having this issue!

They’re still there for me on the same version

Could this be related to your theme? Just for kicks, try a different theme and see if that helps as a workaround.

Best,
Jim

If you’re running a dark mode theme it may be the cause if you haven’t followed this advice:
Note: If the Dark Mode theme is in use when upgrading to 3.1.5.1, you will need to switch to another theme and then back to Dark Mode to see the changes.

Thanks for the responses! I was using the default theme and have tried changing it to other themes and back, but I’m still missing the arrows. Bummer.

At this point, I’d be happy if I could just go back a version to 3.1.5. But I really appreciate the ideas, thanks!

A few questions I can think of:

  1. Have you tried a simple reinstall of the software yet? It could be the assets for drawing those arrows got messed up in the upgrade process.

  2. Is the problem visible in a new test project, maybe using a refreshed copy of the interactive tutorial from the Help menu?

    If the tutorial looks fine: what happens if you go to your usual project and use the Window ▸ Layouts ▸ Manage Layouts… panel, save your layout with both checkboxes enabled below the thumbnail on the right, and then apply it to the tutorial. Buttons vanish? If so, that’s good news as it means this layout may help us solve a bug if you send it in. It also means you can probably do the same thing in inverse from any other project to get rid of it in your main project.

And in the meanwhile, are you averse to shortcuts at all? I can’t remember the last time I used these buttons, since Shift+Alt+Down|Up is so much faster.

1 Like

I had to step away but will try these steps and report what happens. Thank you!

It took me a while to know what arrow buttons you were talking about. I’ve never used them. I figured they were at the bottom of the editor next to the 100% scale button or next to the Include in Compile button. I finally noticed them at the top, next to the split button. I’m using 3.1.5.1 with the Dark Mode theme.

Thank you! I saved the Layout that wasn’t showing the arrows (or the page name I noticed) and applied it to a project that worked normally. Sure enough, the arrows disappeared! Also I could apply the working Layout and make the arrows come back. Awesome!

I will be happy to send the non-working Layout in for any help it might be for solving bugs. Could you help me with knowing where to send it?

It sounds like you may have simply hidden the editor header. You could try with that layout toggling View ▸ Editor Layout ▸ Header View. That header bar includes the Backward/Forward in Editor History arrows, the icon menu and title of the loaded document, the Previous/Next Document up/down arrows on the righthand side, and the editor split toggle button (and the contents jump list in Scrivenings view).

3 Likes

Ok that worked too, Mimetic! I don’t know why this only happened after the update and I never go into View lol, but I must have somehow. So nevermind, that’s embarrassing.

People were so willing to help on this thread, thank all of you. I didn’t realize there actually was a live forum community. I learned a lot about Scrivener with this issue.

3 Likes

Just noticed some more < > buttons. I never used those either. Like web browser buttons or something.

That’s exactly what those buttons are like. :slight_smile: It’s one of my favourite features in fact, as you can much more easily choose to digress and jump around the binder a bit, knowing that clicking the “Back” button a few times will always bring you to where you started the tangent. Click and hold to bring up a full history list, again like a web browser works.

And, just like a browser, one can clear an editor’s document history.

2 Likes

There may actually be some use for that in Scrivener, seeing as how it has no history handling beyond filling the entire monitor with menu entries, somewhat awkwardly. Asking me to delete my Vivaldi history though?! That would be like nuking my bookmarks. :angry:

1 Like