Newbie Em-Dash Question

Hi all,

Just a quick question. I had Scrivener 2.2 (running on OS X Lion) doing fine replacing every double-hyphen with an em-dash, but now it’s stopped doing it, for some weird reason. Don’t know why, or what I could’ve done, aside from mess with the Compile settings (but a bit more fiddling reveals that that couldn’t be it). No idea how this has happened. Anybody got a checklist for me, things I can run through to make sure are checked/unchecked in various places? THanks ahead of time!

In Preferences > Corrections > Substitutions, is “Replace double hyphens with em-dashes” still checked?


Yes, it is still checked. It’s also set up as an auto-replacement in System Preferences > Language & Text. I’ve tried turning one off and the other on, to no avail; it doesn’t work in any case. It’s actually not doing ANY replacements anymore; I just checked, and they’re ALL still checked in Preferences > Corrections, but it isn’t doing it.

Have you tried shutting down Scrivener and restarting your computer?


You haven’t entered scriptwriting mode by mistake, have you? Is the word count still visible below the editor or has it been replaced with “General Text” (which would indicate you’ve somehow entered script mode, and would need to leave it again by going to Format > Scriptwriting and turning off Script Mode).

All the best,

Thanks guys, but I finally figured it out. Apparently, whatever happened had to do with Page View, because turning it off and then back on again did the trick – for some strange reason. (I noticed that the substitutions were working in Composition mode but not the regular Editor window, which made me think of this.) So for some strange reason, the Editor preferences were affecting only the plain vanilla editor, and not the special Page View. Don’t know why, but there it is.

I DO wish they would simplify the overall setting of preferences in Scrivener . . . I mean, as it is, you have the main Preferences window and its various panels, the Page Setup window, the Compile settings window, and then Meta-Data Settings and Text Preferences under Projects, etcetera. Plus, some of these are global to the whole program and all projects, some are limited to affecting only certain views/modes/editors, and some global but project-specific, and others are one-time-only. It would be nice to just have only two – Global Preferences, and then Project Preferences, with the Compile settings stored in the latter. This would no doubt change some people’s workflow – since they’re very used to the program – but it would help new users get the hang of things much faster, and would be much more intuitive.

That shouldn’t be happening - I can’t reproduce it, either. Odd.

“They” is me. :wink:

I don’t see what the problem is here. Preferences are for global settings - that is exactly how it is in any Mac program. The Page Setup window is also a standard Mac thing for setting up page size. Compile sets up your export or print for the current project - you would hardly want that to be global. And the settings under “Project” affect the current project, because it would be highly annoying if every setting you changed affected every project.

That makes no sense to me - having to go into the project preferences to set up Compile would be very odd, and would make for a very messy project preferences interface; it would also make sharing compile presets harder and more complicated, seeing as they would be wrapped up in everything else.

I strongly disagree. :slight_smile:

Anyway, glad you’re up and running with em-dashes - let me know if you can reproduce the problem with them not working in page view, though (what version of OS X are you on?) as that doesn’t sound right.

All the best,