Newbie: q re indents

I have got some documents already written that are formatting fine with a .25 indent for the beginning of each paragraph. Then one that just will not format. I’ve checked the preferences and it all seems to be OK but nothing is working to make this document format with the indents like the others. Any suggestions?

Use the Format/Options/Show Invisible menu command and examine this document at the end of each line. Do you see the “Pilcrow” character at the end of each paragraph, or do you see a curly arrow? If the latter, then you’ve got line breaks instead of paragraph breaks, and line breaks are technically all within a single paragraph—hence the first-line indent setting will not apply to them since they are technically subsequent lines. You could clean this up with a simple search and replace (select, copy and paste the symbol into the Find and Replace fields of the Cmd-F panel—if you’re finding this difficult to do with the mouse, try positioning the cursor to the left of the symbol and then holding down Shift and tapping the RightArrow key).

Thank you so much, that is helpful - except that there is a pilcrow at the end of each line, so it should be OK! Do you think I need to copy and paste it into something like TextEdit and then create a new document, having set that up properly with Preferences? Would that work?

A pilcrow (paragraph return) at the end of every line will impact negatively on layout, spellchecking, and grammar checking.

I’d duplicate the relevant file (to have a backup), then try doing the search and replace and any subsequent editing in Scrivener. If that doesn’t work, there’s always plan B.

If you do use S&R, replace the pilcrow with a space, or words might run together.

To remove double spaces afterwards, just search for double spaces and replace them with single spaces. Run the S&R repeatedly until all the quadruple, triple, double, etc spaces have been removed.

You’ll then need to put in the appropriate paragraph returns where they need to be.

Yes, depending on what you mean by line that could be a problem. If you widen the window with the ruler turned on, page view off and the text block stays the same width even though the right indent marker on the right hand side of the ruler floats with the window width, then the lines are hard wrapped and each one is considered its own paragraph. On the other hand, technically speaking, a paragraph is a line, a long line that is soft-wrapped by either indent or window width settings. So if that is what you mean then you should be okay.

The best way to reset formatting is to cut everything out of the file, click somewhere else so that Scrivener flushes the empty file, then come back and paste using Edit/Paste and Match Style. That should ensure a completely clean paste, as if you had passed the text through a plain-text editor.

But this will not resolve hard wrapping, if that is the issue, Briar Kit’s notes are good for taking care of that problem; you could also use a free plain-text editor like TextWrangler which has a special function, Text/Remove Line Breaks that will do a clean job of un-wrapping text, retaining spaces between words. The only thing you have to watch for is that each paragraph has an empty line between it in the original text—otherwise you’ll end up with one big blob. :slight_smile: