Newbie trying to figure out compile question

Hello:

I have just started using this product, and can’t believe I have not used it until now. I have written 3 books in Word, and love the flexibility this provides.

My question is, I am writing a book that has Chapters and Sections. I am using a different folder for each Chapter, and a different document for each section (the sections are basically a page each). I am typing the title of the section in the grey area at the top (when I start it says untitled), but when I compile it, that does not appear at the top of the section. Do I have to incorporate the section head in the text, as well as in the grey area, or is there a way to have it pull the title into the section automagically?

Thanks

Hi,

Take a look at the “Formatting” pane if Compile. That allows you to determine which elements are included in Compile and how they look. If your sections are text documents, for instance, you just have to tick “Title” in the text documents row. (You can exert even more control, only turning on titles for documents at certain levels, but it doesn’t sound like you need to worry about that just yet.)

Hope that helps, and thanks for trying Scrivener!

All the best,
Keith

I am pretty sure I have it ticked (see attached). Also, is there a way to get back to default formatting in compile (in case I mess something up)

Thanks

The compile settings you’ve posted should just give you a list of titles (probably formatted in a variety of ways), no manuscript text. If that is what you want, that’s fine, but you may want checkmarks in the “Text” column for some of these.

As for getting back settings, generally no, unless you reset while you are playing with them. You can hold down the Option key to enable the Reset button at the bottom. However there are definitely ways to store your settings for future recovery. Additionally if you started from a template, those are always permanently saved into the “Format As” preset selection menu. Right now that is showing “Custom” since you have made changes. If you click on that and go all the way to the top, you should see a preset for the template, next to “Original”. For saving your own settings, you can create your own presets. At the bottom of that same menu, choose the management option and go from there.

In the future you’ll be able to save presets into the project alone, rather than globally, so you don’t have to worry about making a mess of your preset menu with each project’s particular settings.

I got it to print the entire manuscript, but it is still not pulling the title from the title area and putting at the beginning of the section. If I insert it manually there, it shows up, and I could do that, but it would not easily allow me to change the section names if I wanted to. I know this is some setting I have just messed up and can’t see, or some way I have organized the binder that is not correct, but I can’t figure it out.

Any other suggestions?

Also, I keep looking around to find a universal line space setting in compile. Does that exist, or do you need to do it individually in each section?

Thank you all for your help. I am in love with this product and these are just nits. I only wish I had found this years ago.

Thanks

Just to clarify - After rereading the tutorial section - the part I am trying to get to print as the section head for each section is what I have typed in what is refered to as the “header bar.”

Thanks

Mm, do you happen to have “compile as is” checked for the documents in the Contents pane of compile? That would prevent the title from compiling but would compile the text despite the formatting settings. It would also be causing you to get the spacing and such as you see it in the editor instead of it getting standardised when you compile (which should otherwise be happening, since your image shows “override text and notes formatting” checked).

Hi all,

I am having the same problem.
I can see the title, I have check the “title button” into the compile panel. (see first attachment)
I did not check the compile as i button either. (see second attachment)
I obtain the folder title but not the document title.

I try to do the same with the tutorial file and had the same behaviour.
I don’t know where to look out now in order to see the document and subdocument title.


Your second screenshot clearly shows that you aren’t ticking document titles for inclusion in Compile beyond the first level of documents in the Draft:

It doesn’t look as though you have any text documents at Level 1 in the Draft folder (only folders) - in the screenshot, all of your text documents are at Level 2. So either delete “Level 2+” from the formatting list (which will turn “Level 1” into “Level 1+” and have it affect all text documents in the Draft rather than only those at level 1) or tick “Title” for “Level 2”.

Thanks KB :smiley: ,

I think my problem (and maybe cr8it’s) was that I thouhgt that level corresponded to the level just under the folder, not the indentation from the left.

I do have now my title and better control over this aspect of the compile.

Levels are absolute to the Draft. So Level 1 is anything directly inside the draft, level 2 is anything directly under this - this is the standard way of referring to levels in hierarchy. (Remember that you can have text documents on Level 1 of the Draft without them being contained in folders.) I know that confuses a few users at first - just the concept of levels in general - but once you see how it works, it should (I hope) be clear that it gives you a lot of fine-grained control over the output should you ever need it.

Anyway, glad that helped!

All the best,
Keith