Nisus Pro - public beta

Finally, a public beta of Nisus Pro is out: see nisus.com/pro .

Hmmmm. Downloaded fine… moved to Applications fine… application seems to open fine… but it can’t open a new file, which seems a bit extreme, even for a beta version! And it can’t open existing RTF files either.

I have sent in feedback via the Help menu, but I guess this one’s not for me at this stage. Shame – I quite fancied playing with a new word processor today (procrastinating again).

Got the same behaviour. No new file (it says my template could not ne found and that it will revert to the Factory Nisus New File… and then: nada!). No opening file. I’ll try it again when they release a new beta.

– MJ

Strange. I can open as many new files as I want with this beta; I can import as many PDF’s as I want; and I could even open a very old Nisus document, which the beta version found immediately …

There’s just been an update, and the problem is fixed (for me, at any rate). The official message on the Nisus Writer Pro forum reads:

Sorry folks, this is totally our fault. The problem only occurred for those that had never run an OSX version of Nisus Writer. It had to do with missing preferences. We’ve put up a new download that fixes the issue (the file is called “NWP-pb1.dmg” instead of “NWP-pb.dmg”). My sincere apologies for the hassle and confusion.[/i]

It’s a shame (from a commercial point of view) that the only people to experience such a crippling problem were potential new customers who hadn’t used earlier versions. But you can’t fault the response time!

I’m off to play with it now…

Go the same reply after feedback my experience to Nisus’ people.

Going to check.

– MJ

First remark: (this beta version of) Nisus Pro is definitely not for people who often work with very long documents. I imported a 450.000 words rtf-document, tried to work with it, but the only thing I saw was the pizzawheel. Then I tried with a 30.000 words document, which revealed itself much more manageable. Yet in this case too the pizzawheel often was a disturbing presence.

In this respect at least, a wordprocessor like Mellel is vastly superior.

They may stiill have debugging code in there and this is not the final release, so I think I’ll reserve judgment.

Dave

After downloading the second beta (Nisus) I opened a 10.000 words rtf file and it behaved quite well. The 35.000 words one was a bit slower, but considering it had lots of tables, I’m not suprised. A similar size .doc file started the spinning pizza from hell.

Anyway, there are three things I dislike in Mellel:

  1. its inability to work with tables (they are extremely difficult to set),

  2. its UI (comparing with Nisus or even Word)

  3. the dificulty to set the TOC preferences.

Nisus has a better table setting and organizing TOCs is easier.

I’ll be cheking the beta further on…

– MJ

The UI of Nisus Pro is pretty solid.

I’m a newbie though so I don’t know how to test the limits of a WP. I’d like more output formats beyond rtf. Some XML export options would be nice.

I think text rendering will improve and it will certainly improve in Leopard which offers much better text facillties.

I think I’ve got the first version which doesn’t important files right. I’ll probably download another Beta in a few weeks.

I’m a bit miffed about how the scroll bar keeps moving when I change the headings. I hope that’s a bug and not a “feature”

So far, the big UI issue I have with Nisus is that the edit style menu takes over the whole UI.

I like it, but I’m mos likely just going to wait until Office 08 comes out, since I need greater Word compatibility than any other program offers.

It does if you use it for .docs which have been produced under Word by people who don’t manage the style sheet so you get thousands of totally useless styles that nobody ever uses inserted automatically.
But you can manage the UI, by moving some of it out of the drawer as palettes on the desk top – I have the ones I use all the time there: character, paragraph, lists-- then I have re-organised the others on the different panes of the drawer … normally keeping the styles open and I use under a dozen of them.
Mark

Maybe I wasn’t clear.

I do have the list of style in the right sidebar, but if I EDIT one of those styles, it replaces the Page View with the Style Editor. When I’m done, I have to go to the View Menu and choose Page View again.

It’s not a big deal, but it takes some getting used to?