No binder.scrivproj?

[code]The project at “/Users/Username/Desktop/filename.scriv” seems to be of an older format, but no binder.scrivproj file could be found inside it. It may be missing or corrupt, possibly because of a problem with the device on which it is stored, or because of a synchronisation problem.

Try ctrl-clicking on the project in the Finder and selecting “Show Package Contents”, then look for a file entitled ‘binder.scrivproj’. Ensure it has not been renamed by a backup routine. If it does not exist, try restoring from a backup.[/code]

Why do I not have a binder.scrivproj? I’ve opened the package but it is not present. What does the binder.scrivproject do and why has it not been generated?

I cannot find the binder.scrivproj but the XML files with raw text of each chapter is inside my project folder. My document also contained formatting and images. How can I restore this and what “try restoring from a backup” mean? Is this referring to my own backups or automatic backups from scrivener?

Another project of mine does opens as normal but also does not have the binder.scrivproj file. They do both have binder.backup files

Why is it that i cannot open my project?

The binder.scrivproj error message is a red herring.

A healthy Scrivener 3 project will have a project.scrivx file, which serves the same purpose. It’s the file used to build the Binder.

If Scrivener doesn’t find a .scrivx file, it says, “Oh, maybe this project is an older format,” and looks for the .scrivproj file instead.

If it doesn’t find one of those either, it throws up this error message.

So the fundamental problem is that Scrivener can’t open the project because it can’t find the master index file for the Binder.

Why not? The most common cause is a synchronization error: the project was stored in a cloud service and not all of the files have successfully transferred from the cloud service to the local computer. Resynchronize and try again. Or, if the project exists on another device, try opening it on that device.

If that’s not the case, could you give a little more detail on the history of this project? Was it created on this computer in this version of Scrivener, or transferred from somewhere else? When and where was it last opened successfully?

Katherine

Thanks for the message, That helps me understand it better. The file was not created on a Dropbox folder, but on my Desktop so there should not be a synchronization error. I cannot recall if I automatically updated the software. I think I did, but what I don’t understand is that my other project still works. That one should also fail to open if the problem is updating the software. This second project does not have any images.

I’m running on Catalina 10.15.7 with Scrivener 3.1.5 (122568).
I bought Scrivener on 25 july, so if there were updates between 25 July and today then I did update it.

I last opened the project on October 26. If I press the space bar on the file to see a preview, I can scroll down to the first part of my project which does not have any images (these are merely notes), but not the actual book part after it which does include images.

What are your iCloud settings?

In particular, have you configured iCloud to “Optimize Mac Storage?”

Are you using any third party backup or synchronization services?

Katherine

icloud drive is not enabled. I do not sync these files anywhere.

I have decided to stop using this software. The many hours I wasted to get it to work have cost me a lot more than the license to use Scrivener. Pretty much a waste of money, unfortunately.

it refers to the backups created by Scrivener when you close the project. The location can be found under Preferences → Backup.

If the .scrivx file is missing, somthing must have removed it. If you don’t use iCloud Drive with Optimise Mac storage for your project or any other cloud service, and are not saving on a thumb drive or anything similar, it could be that your HD has problems. Files don’t just disappear.
So my guess is that you haven’t given us all the necessary information to enable us to help you.

Scribblydibblydoo, this response is a few months since your original post, but I had the same problem with a disappearing binder file, on several different written projects. Like you, I’m also on a Mac. Mine is running 10.14.6 (Mojave), and I don’t back up automatically anywhere either. I do, however, backup manually to Dropbox, because I have had issues with automatic backups in the past. I also back up to an external hard drive. I’m extremely consistent in how and where I save my files, and I never use automatic sync on Dropbox. I also maintain my computer with regular maintenance, and I’m selective about when I update my OS, because Apple updates can be incompatible with many of the softwares I depend on for regular use. In other words, I only update when I’m sure the new OS will work with my go-to softwares.

Anyway, a few weeks ago, suddenly I couldn’t open most of my projects, couldn’t find any binder files, and couldn’t fix the issue even after trying to follow the directions in the error message that popped up, the same one you saw. I had tried control-clicking on my .scriv files for the various writing projects, and found parts of the contents of my written work as you described, but I couldn’t see any binder files either. Then I noticed that one of my older .scriv files, a backup of the same project, had randomly become a .scrivx file. I don’t know if this is related to the binder thing, but mentioning it anyway because it happened. That wasn’t due to me renaming it or changing the suffix, it just appeared like that one day, without me doing anything differently than I had in my regular routine. I tried control-clicking on that too, but my work still wouldn’t open. In any event, whether related or not, the scriv/scrivx file extension change phenomenon is discussed in the forums here, link is here: https://forum.literatureandlatte.com/t/scrivener-app-folder-renamed-to-scrivx/37446/1.

At the end of the day, I was only able to finally open my projects by downloading older versions of them, which I had manually uploaded to Dropbox. And this I was able to do only after spending hours on google and in the forums here. I did lose a fair amount of work on two of them, and that’s incredibly frustrating, but I was able to recover the bulk of my writing. Still, this doesn’t fix the issue of the binder simply disappearing.

I have to wonder if there is a bug in the Mac version of the software. I haven’t updated my OS since installing Scrivener on my laptop nearly two years ago, and I do not ever do automatic software updates. The binder file thing is a mystery, and doesn’t appear to be resolved. Then there is the whole issue of the changed extensions.The mods have said in the forums that there is no way file extensions changed themselves, but this is what I experienced. I also saw mention of the same from another user in the above link. This thread also references some known issues with Macs that I hadn’t seen in other threads.

Here is what I have done since this all happened, to try to protect my backups. So far, it’s worked and I have had no issues. When I manually back up to Dropbox or to my other hard drive, I compress the .scriv file first. There are known issues with backing up up to the cloud, and Dropbox in particular, which only syncs recent files, not the entire folder structure of each Scrivener project. If this ever comes up for you, if you want more details, there are many helpful threads in these forums about problems that occur when saving to Dropbox and the cloud in general.

Anyway, for my own workflow, compressing the .scriv files has saved me from having anxiety about my projects deciding to suddenly stop opening. From what I understand, a Scrivener project is organized like a folder tree (mods, correct me if I’m describing this inaccurately), and must be saved as such. If you think of a Scrivener project like a filing box without a top on it, things may spill out if you move them, without first ensuring that everything that must remain in the filing box is, in fact, inside the box. I think of compressing the Scrivener projects as putting a lid on that filing box, so that nothing falls out. It’s also helpful to remember that on a Mac, a .scriv file looks just like one file, but it is actually a folder with lots of elements in it.

This may be overkill but I’m not chancing the prospect of losing my work like that again. I then also email myself backups of that compressed file. I also export rich text versions of my project every day. If you do this, make sure you select all your folders within the Scrivener project, otherwise it will just export the one you happen to park your mouse on. This exports everything to folders that contain text files. Therefore, in the worst-case scenario, I will still have the content of my writing, and I’ll still be able to organize it in Scrivener again, though I’ll have to recreate my folder names manually and drag all the text files in one at a time. On top of all this, I print a hard copy every so often, and put in away for safekeeping. Paper may be antiquated, but it doesn’t go offline or lose file structure. Again, this is probably overkill, but tech issues are not what I want to be focusing on when I’m trying to write my would-be masterpieces, and I don’t want to go through this again so I’ve taking backing up to the extreme.

This workflow has already saved me, because a few days after restoring my projects to combat my disappearing binder file issues, a separate thing happened that caused more havoc. I had only been working on my projects for a few days when suddenly I couldn’t open them again. I was about to lose my mind. Then I discovered that a Dropbox update had turned on automatic syncing for a day before I caught it, which caused issues with my file saving structure. Turns out that when I updated the Dropbox app, it had turned automatic syncing back on, and that overwrote some of the Scrivener projects with versions I’d manually uploaded to my Dropbox. Again, Dropbox only saves the most recently changed files within the Scrivener folder structure. It doesn’t understand or account for how Scrivener saves projects, and again I couldn’t open my work. Anyway, this happened days after after the binder file had already disappeared or whatever it was that caused it to not show up when I received the error message after trying to open my file, so as I said, a separate issue.

If you’ve decided to stick with the software, I hope this helps. Best of luck.

Yes, of course it does. The project .scriv is a folder with sub-folders and lots of files. One for every single item in the binder. So the Dropbox app uploads those single files that are changed when you edit a few binder documents. That’s what it’s supposed to do, and what it does. But those files stay on your HD and the copy of the project on the Db server has the exact same folders, files and folder structure.

Dropbox syncing has worked without a glitch for years for me, automatically. Just make sure that you haven’t turned on the new “smart syncing” which makes it possible to have some files only on the Dropbox server and no copy on your HD. If that happens, you might end up with all kinds of problems.

Just wanted to add that I’ve also encountered the same error as the previous posters. Fortunately, I had up to date backups, so no harm done, but it was a bit alarming.

When I clicked ‘show package contents’ as suggested in the error message, all the .scriv folder contained was a ‘Settings’ folder, and within that, a mobile.settings and recents.txt file.

In my case, my projects are stored in a Dropbox folder, and I’m using a Mac with Big Sur 11.2.1, and the latest update of Scrivener. I don’t use Smart Sync and have not had any other problems with Dropbox in a few years of using Scrivener.

The blank project in question was duplicated from an original project - it’s a research proposal that I needed to edit down to a shorter version, so I duplicated the original and renamed it. This was a few weeks ago, and the original opened successfully at that time. Both the new and original project then suffered the reported issue when I tried to open them today. I have updated MacOS in that time but I don’t think Scrivener has updated.

I also had an alias’ pointing to the original project from another folder. This has not caused any problems in the past.

No idea what could have caused this, and like I said no real harm done, but I thought I’d add my experience in case it helped figure out what was going on.

Scrivener is not capable of obliterating its own internal structure. That is, it is not possible to completely remove the .scrivx file, the Files/Data folder, or any other component of the Scrivener project structure from within Scrivener. (As opposed to your own data files, which it can change.)

This kind of error generally occurs when Scrivener projects encounter a tool that does not respect the project’s integrity. A Scrivener project is a folder, with subfolders and potentially hundreds of component files. Any tool that addresses these files individually, rather than as an inseparable unit, can potentially cause this kind of problem.

“Smart Sync” tools of various kinds are the most common example, because they see breaking the project into pieces as a feature: save bandwidth by only uploading/downloading the most recently used files! Save local storage space by keeping everything in the cloud! Nice idea, doesn’t work with Scrivener projects. These tools can be especially insidious when they “helpfully” turn themselves on by default, leaving the user unaware of what’s going on until the problem occurs.

But the same kind of problem can occur in other ways. If you try to upload/download a project via the Dropbox web interface, for example, you’ll typically only get the top level files, not the folders that actually contain your work. Same thing if you try to email a project. There’ve been some similar reports connected with third party backup tools. It’s hard to offer a definitive diagnosis without knowing more about your system.

Compressing a project into a single file, such as a ZIP archive, ensures that all the components will stay together and is the safest way to transfer a project between systems. (And is also a good idea for backup copies.) Unfortunately, Scrivener can’t open ZIP archives directly, so they’re not really very convenient if you work back and forth between multiple systems. That’s where synchronization services like Dropbox come in.

There’s a detailed article on best practices for using Scrivener with synchronization services here:
scrivener.tenderapp.com/help/kb … c-services

Relevant to this particular issue, the key points are:

  • Either use the service’s native application on your local system, or upload/download ZIP archives. Don’t attempt to upload/download a Scrivener project directly to/from the service’s web interface.
  • Ensure all forms of “smart” sync are disabled with respect to Scrivener projects.
  • Check Scrivener’s Preferences → Backups pane to make sure the backup options match how you work. Using ZIP backups is a good idea.

Katherine

This is the alert I get. None of the suggestions helped.

The project at “/Users/apple/Dropbox/ MY FILES/SCRIVENER PROJECTS/*CURRENT/Other/Blog posts.scriv” seems to be of an older format, but no binder.scrivproj file could be found inside it. It may be missing or corrupt, possibly because of a problem with the device on which it is stored, or because of a synchronisation problem.

Try ctrl-clicking on the project in the Finder and selecting “Show Package Contents”, then look for a file entitled ‘binder.scrivproj’. Ensure it has not been renamed by a backup routine. If it does not exist, try restoring from a backup.

Dropbox changed their default settings recently, and the new settings often lead to this issue. More information here: Dropbox Troubleshooting (macOS Monterey) / Cloud Syncing / Knowledge Base - Literature and Latte Support

Is your Dropbox app set to keep all the files in the cloud? Recent updates to Dropbox tend to enforce that, and then people get alerts likethat when they try to open their project(s).

You must make sure that your Scrivener Projects folder, at least, is set to available offline.

HTH

Mark

1 Like

My problem is that “Smart Sync” is nowhere to be found.

Lots of discussion here about the new Dropbox sync settings. Meantime start with How to make Dropbox files online-only - Dropbox Help to read about Dropbox “online” and “offline”. Scrivener (and most apps like it) need files stored in Dropbox to be “offline” and available all the time on the computer and not on Dropbox server. Meantime Dropbox changed things with their new app (Version 160.4.703). See below how Finder presents my Scrivener project folder that I sync with Dropbox. You can read about Dropbox’s update at Dropbox Update for Mac - Dropbox Help

1 Like

This also works on a per-file basis (which was how I was doing it till I saw this and the penny dropped with anvil-like force that you can simply change the setting at folder level…). So if you’re getting the missing-binder.scrivproj message off a Dropbox file, just right-click on the file or the enclosing Scrivener folder and choose Make available offline, and it should then open, without the need to get your head round Dropbox’s under-the-hood changes.

1 Like