No blue when I copy

I have just upgraded my MacBookPro to Big Sur. Now when I copy, the text does not go blue. I can tell that it has copied by a symbol at end of section. It will then paste correctly. But how do I get the blue highlight back?

I don’t know what you mean. You have to select text before you copy, so maybe you mean “when I select, the text does not go blue”? Then I wonder if you mean “it isn’t highlighted in blue”. If that’s what you mean, highlight colors can depend on settings in Scrivener Preferences, System Preferences, Scrivener Themes, whether you’re using Dark or Light, etc. If you can show us exactly what you mean, someone can probably help.

Sorry for lack of clarity. I meant blue highlight when I select for copy and paste. There is no highlight in Scrivener since upgrading to Big Sur. but there is highlight if I select in Pages. Therefore suggests this is a Scrivener bug not OS bug. You mention preferences. Where in Preferences can I find highlight on off and colours?

Highlight color controlled by the operating system, not Scrivener (far as I know). However, I cannot discount that maybe somewhere in Scrivener they give you that control. I suggest you hunt around in Preferences. Noting behaviour of Pages is not really relevant. However, you can try Apple’s Textedit app which uses the same Apple text display/editing engine as in use by Scrivener (as I understand).

Check in the Apple’s System Preferences in the General Tab and see what colour you have told the computer to display highlighted text. If the computer does not respond to you changing it to something else–and then back to blue–then try re-booting. If it still does not work as you want, perhaps worth asking Apple via Apple Care as a Big Sur bug.

Another question is what theme are you using?



In addition to the other suggestions, make sure you’ve installed our Big Sur compatibility update, Scrivener 3.2.2. The Scrivener → About Scrivener command will tell you what version you have.


Scrivener does allow the text selection to be customised in Preferences, under Appearance:Main Editor:Colors. Composition Mode also has a colour setting for text selection.

Light Editors also have a color setting (on the Mac, at least).

Still no colour when I select for copy and paste. but if I select in text edit, text is selected in blue. But not in Scrivener. And page does not fit screen! I’ve tried every way without success. All since updating to Big Sur. (Yes, my scrivener version is 3.2.2). I’ve booked a call with AppleCare ttomorrow pm hoping that this is a OS problem which they can sort.

It isn’t noted (or I missed it) whether this issue(s) presents itself in more than one project. If it’s just in one, you could try resetting the project’s display settings as explained in this Literature & Latte support article: … y-settings

Problem solved by Alex at Scrivener support. I’m copying his email here in case somebody else has same problem.

I’m sorry that didn’t work. I’m wondering if perhaps you have the text selection colour set to the same colour as the background of the main editor. I’d like you to please go to Scrivener > Preferences > Appearance and select “Main Editor” from the menu. Select the “Colors” tab, then the “Text Selection” option. Is the colour swatch the same colour as your Editor background? And even if it’s not, could you try changing the colour anyway to something that would definitely be visible over your editor background colour? Does the highlight reappear when you do this?