No Caps -v- Spell Check

Well now, here’s an interesting conundrum.

I write a lot in chopped up sentences
where I break things down
into quasi verse
like I’m doing here…

The default settings in Scrivener want to capitalize every new line. I found the setting in Preferences > Corrections that turns that off. But it’s still happening. I couldn’t get it to stop until I also turned off “Correct spelling errors as you type” in the ‘Spelling’ section above the ‘Auto Capitalization’ section.

I rather like the ‘Correct spelling as you type’ feature. I’m a fast, but very inaccurate typist, so that helps. But it seems that the auto-spell correct over rides the turned-off “Fix capitalization…” function.

Is there no way to turn off capitalization AND have auto spell correction as I type?



I cannot reproduce this in my copy, but this isn’t Scrivener technology, so I’m not sure how to advise you on what is wrong.

You try the same combinations of settings using TextEdit and the “Text” tab of the Keyboard System Preferences pane. The options in Scrivener as well as the underlying behaviour are the same exact pieces of code used for these, so we should see the same behaviour between the two. For me, in both Scrivener and TextEdit, with capitalisation disabled and spelling correction enabled, the beginnings of my lines are left alone, even if the first word is misspelled and corrected.

If it doesn’t work in TextEdit either it could be your OS X version or some other global condition—installed software even. If the two behave differently than the problem is a mystery. You might find discussions on the Apple boards or similar.

Yeah, it’s weird.

I’m running macOS Sierra on one of the new 2016 MacBook Pros…

I’ve attached a screen shot that shows how I have my preferences set… I have “Fix capitalization of sentences” turned OFF, but every time I get to a new line… I get a first letter capitalized.




Did you get a chance to check with TextEdit and the same system preferences for auto-correction and capitalisation? Oh I also meant to ask, does the capitalisation option seem to have any effect at all, or is just the beginnings of lines that are abnormal?

Forgive me I just sent a long message with several screen shots of settings in different preferences, and the complaint that I was still getting auto capitalization…

After submitting I went back to Scrivener and had the bright idea to re-check THOSE settings.

Turned out auto-capitalization was turned back ON. Duh.

I re-toggled it off, and now it seems to be working the way I want.

So I deleted that previous reply post with all the screenshots.


Okay! Glad to hear you got it fixed.