No double spacing

I have spent a little time with 025 now, trying to get double spaced output from ODT. No go.

This is a project from 024. I had been trying the same thing in 024, attempting to get double spaced output in the .odt file. I couldn’t make Scrivener give me double spacing, so I waited for 025, hoping that it was a bug that Lee would fix.

The bug still seems to be there (if it is a bug). The project was started from the Blank template. Under the “Draft” folder, I have four section folders. Right now, every section folder except the last one has text files. Each section folder contains one text line (no carriage return): a centered and bolded number as a section marker.

My compile settings are “Custom”:

  • Contents: All items, folders and text files, are included
  • Formatting: Level 1+ folders, “Text” checked; Level 1+ text file groups, nothing checked; Level 1+ text files, “Text” checked
  • Formatting, Preview: Level 1+ folders, Line spacing 2.0, centered; Level 1+ text file groups, defaults (Line spacing 1.0, left justified); Level 1+ text files, Line spacing 2.0, left justified
  • Separators: Text Separator, Custom, “***”; All other separators, Empty Line
  • Text Options: Plain Text Conversion, all three checked; RichText Conversion, nothing checked
  • Footnotes/Annotations: all defaults, that is, I haven’t altered this since I don’t have any footnotes or annotations in my documents

To compile, I choose “Open Document Format (.odt)”. The resulting ODT file is single spaced. I have also tried Preview, PDF, RTF, .txt, .doc, .html, .xhtml, and .ps. None of them honored the double spacing specified in Formatting->Preview.

Perhaps it’s not a bug and I have just done something wrong. If so, could someone please let me know what I misunderstood? And if there is a way to get double spaced output, could someone enlighten me?

Thanks for your help.

Just to get the simplest answer out of the way, did you make sure to check “override text and notes formatting” in the top of the Format tab in compile? It’s definitely possible to get double-spacing, but there are some bugs with compile so it’s possible your set up is somehow triggering one. If the formatting is checked for the override (and if you don’t have “compile as-is” checked in the contents pane), we’ll just need to pick through and figure out what’s causing Scrivener to hiccup.

Wow. I was sure I had it checked. And I am almost positive that at some point, I did have it checked. But I just checked, and it was not checked! So, I checked it. :smiley:

And it made no difference. Still a single-spaced .odt file.

I also made sure that “Compile As-Is” was not checked in any folder or text document in the project.

May I make a UI suggestion and request that the checkbox for “Override text and notes formatting?” be moved to immediately above the “Preview” panel that it controls? I think that the checkbox gets a little lost up there so far away from the Preview pane. Or did I miss some higher purpose that requires it to be where it is?

Any ideas on why I’m not able to get double-spaced output given the compile settings above?

Figured it out. Not sure why my compile settings ended up like they were. Or perhaps it was my understanding of how the compile interface worked. But everything is functional, and double spaced, now.

thanks,
-jim

Jim – So sorry I left you hanging here. Good to know you got it working in spite of deficient help! Are things cleared up now for how the formatting in compile works?

Thanks for checking back, Jennifer. I appreciate it.

As far as the original problem, I’ve figured out how to get what I want, and teased out how the compile interface works. I’ve got my text formatting mostly under control now.

Compile itself still produces those little black boxes on at least .odt and .doc formats, but that has been posted separately.

Well, while I did produce something that my critique group could read, when I tried to produce Shunn Standard Manuscript Short Story Format (http://www.shunn.net/format/story.html), I failed.

So I tried to see if there was any combination of compile specs and output format that would work. The closest I got was using PDF or Postscript. RTF was the closest runner-up, but (a) it left-justified the separator, and (b) page margins were unacceptable.

Shunn short story format requires that prose bodies be double-spaced and separators be centered on the page with 1 blank line above and 1 blank line below. This is not possible to produce with the current 026 beta. And that means, for me, that I will have a significant number of edits to produce submission-ready copy. And please correct me if I’m wrong: I should be able to produce ready-to-submit copy (minus header, footer, and page numbering issues) if I only have text, yes? That’s the goal?

'Cuz we’re not even close yet. Here are my current Compile Settings, which started from the Short Story template:

Contents: all text files included, no folders included, First Page Header "As-Is"

Formatting:
    Override text and notes formatting checked
     Folder Level1+: Text checked
          font: Courier New/Normal/12pt, line spacing 2.0,
                centered, left indent .50
          no Title Settings, Page Padding 0 lines
     Groups Level1+: Text checked
          font: Courier New/Normal/12pt, line spacing 2.0,
                left justified, left indent .50
          no Title Settings, Page Padding 0 lines
     Text Files Level1+: Text checked
          font: Courier New/Normal/12pt, line spacing 2.0,
                left justified, left indent .50
          no Title Settings, Page Padding 0 lines

Separators:
    Text Separator: Custom: "#"
    Folder Separator: Empty Line
    Folder and Text Separator: Empty Line
    Text and Folder Separator: Empty Line

Text Options: (nothing checked)

Folder/Annotations: only "Remove annotations" checked

I was trying to find a way to get double-spaced text output with centered “#” separators with a single blank line before and after. As I said, I failed. The idea was to try various combinations of leading and trailing carriage returns to produce blank lines at the beginning and end of adjacent text files. As noted in the Compile Settings above, line spacing was always 2.0.

In this table of results, “a” and “b” mean “after” and “before” and refer both to the number of blank lines in the text files and in the output file.

For example, “File 1 a 0, b 0: a 0, b 1.” The “a 0, b 0:” portion means that the end of File 1 had no carriage return after its last closing period (a 0), that is, “carriage returns at the end of the file (what I called “after”) is 0.” And that the file that followed had no carriage returns at its beginning (b 0), that is, “carriage returns at the beginning of the file that follows File 1 (what I called “before”) is 0.”

The “a 0, b 1” portion at the end means that the output file displayed no lines after the file in question (a 0) and one line before the next file (b 1). Note that “after the file” implies “before the separator” and “before the file” implies “after the separator.”

I also captured whether or not the text was double spaced and whether or not the separator was centered:

ps, double spaced, separator centered
	File 1	a 0, b 0:	a 0, b 1
	File 2	a 0, b 1:	a 0, b 2
	File 3	a 1, b 0:	a 2, b 1
	File 4	a 1, b 1:	a 2, b 2

odt, single spaced, separator centered
	File 1	a 0, b 0:	a 0, b 0
	File 2	a 0, b 1:	a 0, b 2
	File 3	a 1, b 0:	a 1, b 0
	File 4	a 1, b 1:	a 1, b 1

doc, double spaced, separator left justified
	File 1	a 0, b 0:	a 1, b 0
	File 2	a 0, b 1:	a 1, b 1
	File 3	a 1, b 0:	a 3, b 0
	File 4	a 1, b 1:	a 3, b 1

txt, single spaced, separator left justified
	File 1	a 0, b 0:	a 0, b 0
	File 2	a 0, b 1:	a 0, b 1
	File 3	a 1, b 0:	a 1, b 0
	File 4	a 1, b 1:	a 1, b 1

rtf, double spaced, separator left justified
	File 1	a 0, b 0:	a 1, b 0
	File 2	a 0, b 1:	a 1, b 1
	File 3	a 1, b 0:	a 3, b 0
	File 4	a 1, b 1:	a 3, b 1

pdf, double spaced, separator centered
	File 1	a 0, b 0:	a 0, b 1
	File 2	a 0, b 1:	a 0, b 2
	File 3	a 1, b 0:	a 2, b 1
	File 4	a 1, b 1:	a 2, b 2

The closest were PDF and Postscript. Both were capable of producing double spaced centered separators. But this is not correct Shunn format. If I was working on a novel, I would have many hundreds of edits to make to fix Scrivener’s current inability to produce proper format.

Note that we what we’re faced with is an often-used and necessary format that puts a requirement on the code that it seems not to currently handle – the separators must be surrounded by a single blank line before and after, but the prose must be double spaced. So separators might need their own preview capability similar to the existing “Override” formatting UI.

And that’s not counting bugs like “odt does not honor line spacing” and “doc and rtf don’t center a custom separator” that are obvious in the table above.

Hope this helps.