No Kindle icon after updating

Just following up on the other thread about upgrading Kindle which then eliminates the nice blue A on a mobi file. I’ve done everything the other thread mentioned, but nothing works. I still get the blank white icon on my desktop (which is where I have the mobi files saved when I’ve done Compile). And in my Kindle app for iPad, the main cover now no longer shows up – just a white icon with .DOC on it. Any thoughts on what can be done?
Thanks in advance!

.DOC?

  1. Any chance you have inadvertently compiled to .doc format instead of .mobi??

  2. I don’t know the other thread you referred to, but have you tried reasserting for the Finder that Kindle app is the app which mobi files should open in?

-gr

Hi, thanks for responding.
No, it’s still a mobi file. And here’s what I see when I select the KindleGen line in Compile:
Screen Shot 2016-08-04 at 6.53.23 AM.png

This happened once before (the blue A icon disappearing), also after a Kindle upgrade, but I can’t remember how I fixed it.

(I am definitely out of my depth on this one. --gr)