no scrolling in Lion

Hi, I have just installed Lion and the Lion update for Scrivener, but can’t get any document to scroll, which makes it unusable at the moment. Any suggestions appreciated.

I’ve seen one other user report something similar, but I’ve never seen this, and all of Scrivener’s scroll views are standard and handled by OS X. What scrolling device are you using? Does TextEdit scroll? Have you checked your System Preferences?

Are you aware that Lion has switched the direction for scrolling on trackpads, so that down is now up and up is now down? Could that perhaps be the issue?

Thanks,
Keith

I noticed that backward scrolling on my Magic Trackpad.
Reversed its direction, with the pad tilting downhill.
Now scrolling is normal. Except left and right are reversed.
Crazy!

You can switch that reversal off in the Trackpad System Preferences pane; Scroll & Zoom tab. With it back to the old way, you can turn the trackpad around and get your lefts and rights back to where they should be, too. :slight_smile:

I am having this issue too. It was happening before and after the update. I can scroll the pane with the list of documents, but I cannot scroll in the editor. And yes, I am scrolling the “lion” way. I can also scroll fine in TextEdit just fine.

Anyone have any idea? I am so frustrated :frowning:

Update:

I can scroll when I slightly resize the window. I also can scroll in the new Full Screen mode. But when I open a project, I can’t scroll until I resize the window.

Could you try opening Console and pasting any messages here? Activate Finder, press Shift-Cmd-U to open your Utilities folder, and double click on the Console icon. Make sure the “All Messages” item is selected in the sidebar (click “Show Log List” if necessary). Then try to scroll, and copy paste anything that pops up there to a response.

Update: Interesting, so can you reproduce this in any other project you’ve not opened and fiddled with yet in Lion? Does the bug go away forever in a project once the window is resized, or does it re-appear after a re-launch and require another resize event to fix it?

Is this in page view mode or regular mode? If in page view mode, does the problem only occur in page view mode?

Keith, this is in Page View.

Amber, very strange. Once I resize the window, the problem does not come back. When I close the app and open it again, the problem goes away.

Could it be that it only happens when a window is a certain size? Very weird. It just may be quirk in Lion’s scrolling and Scrivener had been open at just the right time, etc? I don’t know.

I will let you know if it comes back. Right now this is the only project I have going, so I don’t have any others to try it with. Hmmm.

That’s very strange that it stayed fixed after closing and reopening the project - good, though! It does indeed sound like a particular UI size was causing it. Fingers crossed that it only affects projects newly opened on Lion, but let us know if it happens again. cantata8660 found exactly the same thing - he scaled the text to 100% then back to 150% and the problem went away, and stayed fixed after quitting and re-launching. So, so far at least, it seems like a settings issue on some projects that are newly opened on Lion, and that resizing or rescaling clears it. We’ll keep our eyes out though.

Thanks,
Keith

I’m experiencing the same issue. Scrivener 2.1 on Lion. I get expected scroll functionality at all text scales with the exception of 150%. If I scale the text to a different percentage and return to 150% I again lose scrolling. I’ll simply use 125% until you sort this out. Let me know if providing more info will help you troubleshoot the problem.

Interesting. Could you please let me know the following:

  1. Is this in all views? That is, does this happen in the main window, or only when in Lion’s full screen mode, or both?

  2. What about in Composition Mode?

  3. What happens if you resize the window slightly? Does scrolling return?

  4. Are you in page layout mode or just regular text-wraps-to-fit-the-width-of-the-editor mode?

  5. If you are in full screen mode, what happens if you turn off fixed width in the Editor pane of the preferences?

EDIT: I just briefly reproduced it myself. I entered full screen in page layout mode with the pages centred, and hid the inspector. After that, the scroll bar moved down the page, but the pages did nothing. After resizing the binder, I was then unable to reproduce it no matter what I did, even reopening projects. It seems like some Lion bug where scroll views don’t like certain scales when the scale has resulted in a particular view size (possibly non-integral values?). Hmm. If I could reproduce it consistently I’d be able to investigate better, so anything you can think of would be useful.

Thanks and all the best,
Keith

Not a problem here at all, in any % view and with scrolling on either mouse or trackpad.

  1. It only seems to affect page layout mode. It doesn’t matter if I’m in full screen or windowed mode.

  2. Scrolling actually seems to work in composition mode at 150% text size and the others.

  3. Resizing the window has no impact (actually it seemed to fix it on one occasion, as I typed this). It seems to be related to 150% size in page view mode.

  4. Page layout.

  5. no change that I can tell.

Thanks for your help. I am at 125% scale for now :slight_smile:

Do you have page layout centred? If so, what happens if you change the preferences to have page layout on the left instead (un-tick “Center pages” in the Editor pane of the preferences)? My guess is that the centring scroll view is the culprit.

good thinking! Sure enough, when I deselected center pages, the document scrolled as it should. I’ll try it on a few more documents to be sure, and let you know if it does not fix all for the time being.

Great, thanks! I have an idea, which has worked in brief testing, for a different way of doing the centring. I’d be grateful if you could confirm that this does indeed only present a problem when page layout view is centred before I go ahead and start coding, though. If so, and if you can reproduce the problem consistently in this situation, then once I have something working I’d be grateful if you could test it for me seeing as I can’t get the problem to show up now.

Thanks!

All the best,
Keith

I tried about 8 different documents including the interactive tutorial and some of my own creation and found consistently that at 150% and centered in page view, no scrolling occurs. Uncheck centered and leave the other variables unchanged and scrolling works for me.

I’d be happy to test a fix.

Appreciate the attention you’ve given this. Definitely exceeds my expectations. Thanks!

I’m having a problem scrolling in Lion. One project is working fine. The other won’t scroll when the binder is showing, but will (centered and not centered) when I close the binder. I can show the binder and have the editor not centered and it does scroll.

Jenny

Thanks, kbavier.

Jenny, just to clarify - the scrolling problem only occurs when you are in page view and it is centred, right?