No style really is no style

I have a document, most of which is done with literally ‘no’ style.

Reminds me of an old joke at a SciFi convention: “No costume really is no costume”.

When I export it, there’s very little formatting. I want to change it to double spaced, but in Word, again, it has “no style” including default, so there’s no way to change it. Sure, I could “select all” but that’ll get the chapter headings too, which I don’t want to do.

I’ve gone into the compile options and changed things, but nothing seems to change the text spacing.

Fine, so I figured I’d go and just change ‘no style’ to Body.

Body doesn’t even show up as an option.
image

If I go into the compiler, I setup “Section Text” to show as double, but it never compiles that way.

On my “Section Layouts” I finally figured out how to override it, I had a block that said ‘as is’ but it seems strange I can’t just somehow indicate either ‘no style’ formatting, OR make text default to ‘body’ style.

What am I missing?

== John ==

Have you Right/Control-clicked your chosen format to Edit/Duplicate and Edit the format, and adjusted the Section Layouts to the font/spacing you want, then ticked the “Override text and Notes Formatting”?

I don’t use Word, but my “No Style” in Scrivener is styled as “Normal” in Nisus Writer Pro … the equivalent of “Body” in Word.

:slight_smile:

Mark

  1. FWIW, the default paragraph style in Word is called ‘Normal’. When I compile, my unstyled paragraphs show up as having style ‘Normal’ in Word. (Can there even be a paragraph in Word with “no style” at all?)

I’ve gone into the compile options and changed things, but nothing seems to change the text spacing.

  1. Definitely going to want to sort that out, because it is a simple matter ultimately and one you will want to have control over!
1 Like

I don’t think so. You can apply whatever formatting you want on top of the “Normal” style – thereby creating a mess that will make your editors mad at you – but I don’t think Word will let you create completely unstyled text.

So, a make-do solution in Word for the OP would be either

  1. to modify the linespacing of the Normal style, or better yet,

  2. search for style Normal, replace with style Whatever and then alter the linespacing of the Whatever style.

Of course, figuring out how to make Compile do their bidding is the real solution, but in the meantime…

Making Compile do their bidding is also a Scrivener task, and on topic for the Scrivener fora. Whipping Word into shape is a question for Microsoft’s support team.

I understand that the option to use ‘no style’ for most of one’s manuscript makes sense. Until it doesn’t. In my case, I need to use a style for everything.

But there seems to be this strange quirk when compiling to an epub or mobi, where if I somehow missed applying a style to a line of text, it shows up in the compiled version as HUUUUUUUUUGE!

I write in an 18-point font, suddenly, a line that has no style applied to it appears in a mobi or epub as if it were 32 points high. And since ‘no style’ appears very similar in The Editor to the styles that I use, I can miss a line or two.

But ‘no style’ really is ‘no style’. What I mean by that is it’s the only ‘style’ you can’t search for. If I were able to do that, I could head off these compiling disasters that are invisible in The Editor.

Is there a chance that we could make it searchable?

image


Are you sure your compile format doesn’t have the body text / no style set to compile like that ?

Why do you need a style for everything?

And if you do need a style for everything, why not change them to be more unique? You can always use the Compile command to change them back for the output document.

Also, note that Scrivener can be told to highlight styled text in the Editor.

I tried that, but it got in the way more than it helped.

I’ll try to check that, but your graphic boggles me, bc I get a drop-down menu like that, but ‘no style’ is not an available choice. Maybe that’s a Mac thing?

Could be. I don’t know. (I am running Scrivener under Windows. ← I am saying because I don’t know what system you are running.)

I can’t figure out how to even check for that.

Check for what, my friend ?
I meant I don’t know if you are Mac or Windows. (Your profile doesn’t say.)

Check for that. I’m on Mac. I also have no selection for ‘no style’ in that drop-down menu.

Check for all the layouts. (Top section of my screenshot.)
Pretty sure you have one or more causing the huge font.

If you want the no style to look like in the editor, all you have to do is uncheck the checkbox I highlighted. Otherwise, format it the way you want it. You can even set it to be like one of your style is :
image

I did check that, earlier. All section layouts actually say I am using 12-pt font (!!!)

And now I wonder: Maybe 18-pt in The Editor at 100% looks ‘good’ to me, or ‘correct’ to me, and in epub or mobi I have the text set so it looks ‘good or correct’ there, but it really comes in to the epub/mobi as 12 pt (for the styled text) and for text with no style it honestly doesn’t know what to do, so it makes it the same size as what I have in The Editor.

I guess I should try anl experiment.

18 is quite big. That’s for sure.

In that case check for a layout with the checkbox I highlighted that isn’t checked.

But unless you have your styles listed in the “styles” pane of the compile format, they have no reason to go from 18 to 12pt. And that then can’t be it…

Perhaps you have a style that is listed there and formatted to be huge ? That would make more sense.

Export, zip and upload your compile format here (or PM me) if you want. If compatible with Windows (that I don’t know), I could have a look for you. (Not your project hey : just the compile format.)

I think it might also be caused by a bad style name. Avoid spaces.

My Section Layout window has something different at the bottom of it:

I guess that’s different for Mac.

And every time I go to edit the format by changing the default text size from 12 it crashes the entire thing.

It’s different because you are compiling to epub. It is actually my screenshot that is wrong. (I just didn’t think of it. My bad.)
Try setting your layouts (all of them) to use editor formatting. That should fix your issue.

By the way, using styles everywhere ain’t the best way to go about things. Just saying.
We’ll talk about it later, maybe. For now, lets just get your compile working.