No user error


I just started to use Scrivener yesterday, so this might very well be a typical newbie question.
In a new project, I tried to import a .docx file into the research folder. I get a warning saying “no user error”, and then the .docx file is imported as an empty file, so without the text it contained.

What did I do wrong?

Thanks very much for the help!

What is the file path for the document you’re importing? There was a problem with the importer previously which would result in this error if the DOCX file had certain special characters (such as œ) in the file path, but that should have been fixed a version or two ago. If you check Help > About Scrivener, are you using 1.8.6?

I was importing a .docx file, without any special characters.
I am using version, but still in the free trial-version. Could that be the problem? Is it impossible to import files in the free trial period?

No, there’s no difference between the trial and regular versions except the time limit; you’d just register that installed copy to remove the 30-day lock. Do you have Word 2007-2013 installed? If so, try switching which converter Scrivener uses for the import. Go to the Import/Export tab in Tools > Options and click on “Import Converters…”. Select DOCX from the menu on the left, then Microsoft Office from the right menu and click OK to that and the Options. Does the file import properly now? If not, try resaving it as an RTF file and importing that; RTF doesn’t go through the same conversions (since Scrivener’s internal format is RTF) so that frequently gets past import quirks arising form the conversion process.

Thanks MM: I switched the converter as you suggested and now it works fine. Thanks for your help!