Not all folder and text levels selected in compile

Hello :smiley:

I am attempting to compile my project, but I cannot get all levels of the folders to be selected in the layout. As in, when I click on the folder levels only some are highlighted in yellow despite them all being on the same level. I have tried using the default options, and fiddling with the levels endlessly but simply cannot get it to work.

I have attached a screenshot of my layout. It’s very simple. Just:

Text
Folder

Text
Folder
Text
Folder
Text
Text

And that it all. Is there any reason why some documents would not be selected despite them being on the same level?

Many thanks all

Can only see a narrow vertical strip of your screenshot…

Are you trying to do the selection in the binder? I believe it has to be done in the Compile dialog.

Yeah sorry, I was just hiding the titles. All it’s missing is the titles.

Nope, doing it in compile. You know how when you select a level in compile the relevant ones show up yellow on the side? Only a few are doing that and formatting is only being applied to some files, not all on that level.

Afraid I’m out of my depth on this and had best shut up and bow out. Apologies.

I am far from an expert here, but here goes my take on what you are saying:

when i compile, i don’t find any yellow selection over the items to be compiled, but rather checkboxes next to each one (left of the icon for each) marked ‘Include’ – left to right, I find Include, Title, Pg Break Before, and As-is.

So, whatever has its check box under Include ticked, will be included in the compile, and if you option-click on any one box, it will turn all of them ticked or not-ticked.

I can also click on the name of any item, folder or text, and it shows up yellow, but this has nothing to do with whether it is included in the compiled output.

  • asotir

There are a few things that affect the yellow highlight when selecting levels in the Formatting pane of the compile window. But first, I suggest clicking on all of the various levels in the Formatting pane; do any of them cause the binder documents to highlight? I ask because a lot of people have trouble with the ‘levels’ concept.

If you have “as-is” checked for a document, then selecting the corresponding Formatting level will not highlight it; the highlight is only for documents that will be affected by those formatting settings, and as-is excludes those documents.

If you have your compile target (in the Contents section of compile) set to something that excludes the documents in question, then the yellow highlight will only apply to the subset that is included.

There might be more levels than are visible in the Formatting window. Try to scroll down (or use the arrow keys when one level is selected) to be sure.

That’s all I can think of at the moment.

Hi,
I’m having a similar problem. and this is the thing that frustrates me TO NO END about scrivener. I so enjoy it for writing but it is TOTALLY USELESS AT EXPORTING!!!

I’m compiling most of a manuscript for PDF. I selected the included documents, and I compile them ‘as-is’ because I have formatting going on.
I select to include Titles. No titles show up.
I check all the formatting and including etc. Still no titles.
I try changing various settings - sometimes I get titles as ‘(null)’, but generally they just aren’t there.

I notice the problem with highlighting (as per this thread) - when I select a level to adjust the settings, it doesn’t highlight. Documents that are NOT included in the compiled draft DO highlight, but not any of the docs that ARE supposed to be in the compile.

I tried exporting as a Proofing format instead of Publishing - for some reason, that generates titles, but then f*cks up the table of contents.
I’ve been going back and forth for over an hour, so now I give up.

GRRR!!!

First. Take a deep breath. Compile can be difficult if you’re doing anything complicated, but it’s hardly useless. You just haven’t hit the plateau of the learning curve is all.

Second: The “as-is” checkmark disables titles as well as formatting overrides. If you don’t want any of your documents to have fonts overridden (or any other formatting for that matter), but you do want title from the binder to be used as specified by the Formatting pane, then un-check the as-is boxes (go to compile’s Contents pane, CMD-click on one of those checkboxes until they’re all un-checked). Then, in the formatting pane of compile, near the top of the list of levels, there’s an “override text and notes formatting” box. Un-check that.

Now you should get the highlights as appropriate, given what segment of the draft folder you have selected in the Contents pane of compile and/or the Filter settings near the bottom of that pane.

thanks, that did it! But this clearly isn’t the only time I’ve been yelling at Compile. Going away for a few hours helps :slight_smile:

Compile does take a bit of getting used to, but it’s a bit of a damned-if-you-do, damned-if-you-don’t situation, because unfortunately, there’s no way we can offer complete flexibility to structure your project how you want and then provide a big button that can take that possibly unique structure and know how to compile it into exactly the sort of document you want.

So our options are:

  1. Limit the structures available in the Draft folder (force the user into using chapters, or chapters and scenes, or such). But this severely limits the writing and structuring process which is really the area where Scrivener is the most useful.

  2. Don’t bother with much of a compile at all - just have a button that takes all of the text in the Draft folder, puts a blank line between them, and exports them to a word processor so that the user can deal with making the text look how they want afterwards. (You can already do that by selecting the “Original” compile preset.)

  3. Offer the user enough options to be able to turn their draft into almost any sort of document. This is the option we’ve taken. But the trade-off here is increased complexity, and potential user frustration at trying to deal with all the options.

We are continually looking at ways to make it easier, or at least to make it more obvious what various things in Compile do or are needed for, and we have some ideas about that for the future. But I don’t think it’s ever going to be as simple as anyone would like without drastically reducing the usefulness of the program in other areas.

What I would say is:

  • Only ever use “Compile As-Is” as a last resort; the same as “Page Break Before”. Those are for overriding settings that are normally made in Compile.

  • The “Formatting” pane of Compile is the one you really want to familiarise yourself with. Once you understand how that works, everything else is fairly straightforward.

  • When setting up “Formatting”, think in terms of levels and types. If you want to set the formatting, or whether a title appears or not, for a particular type of document in your Draft, think about what level it is on compared to the Draft folder and what type of file it is. E.g. in a Draft folder set up like this:

Draft/Manuscript

  • Part (folder)
    • Chapter (folder)
      • Scene (text)

If you want to set up how the title looks for chapters, you need to set things up for level 2 folders in “Formatting”.

All the best,
Keith