Not loading projects on MacBook Pro [OS 10.11.3, Scriv 2.07]

UPDATE: As I was sending an email to tech support, Scrivener suddenly loaded a project file I’d tried to open around 10-15 minutes previously. And it’s opening the other files it wouldn’t normally. There was no error message or input on my part.

I have Scrivener on two Macs: a MacBook Pro (MacBookPro11,3) running OS 10.11.3 and a MacBook Air (MacBookAir5,2) running Mac OS 10.11.2.

My Scrivener projects are contained in a Dropbox sub-folder, which is synced between both Macs.

Today, I’ve found that Scrivener projects won’t open on the Pro, but will open on the Air.

When I try to load an existing project file or start a new project on the Pro, Scrivener freezes and the spinning beach ball appears. I have to force quit the application.

But the same files open without a problem on the Air.

I have tried to delete the Scrivener preference file (as described in this forum post) and completely uninstalling Scrivener, using AppDelete, and then reinstalling Scrivener. Neither helped.

I checked each file on the Air and made sure that all the projects I tried to load weren’t set to load to full screen. I also created a new, blank project on the Air to see if that would load on the Pro: it didn’t.

Is this a known issue with El Capitan 10.11.3, or is there another route I can take to get these files to open on the Pro?

I’ve tried this fix for the known issue of Scrivener crashing under El Capitan. But OS X said there was no “NSFont” file on my Mac.

  • Richard

EDIT: Changed the subject of the post to make it accurate. And added an extra step.

I’m a little bit confused by the last line in your post, as you say the MBP, where the projects won’t open is running 10.11.2, and you ask if its a problem with 10.11.3. Also, the post you say you looked at was referring to problems with Mavericks, not El Cap. Go to: … =2&t=33573

which concerns similar problems to yours using 10.11.x, in which kewms from the support team posts:


Mr X

Sorry: I got the OS versions swapped over: the MPB runs 10.11.3 and the Air is running 10.11.2. I’ve corrected the main post.

I’ve already tried the first fix for El Capitan, which didn’t help. The second fix isn’t applicable because the freeze occurs when creating new projects on the Pro and when loading projects that are not set to open full screen on the Pro.

  • Richard