Novel Template: imported/pasted para indents different

I’m hoping someone can help me with a problem I’m having. I’m using the novel template and pasted the text of a chapter (that I’d written before even owning Scrivener) into the template. There are no paragraph indents and when I do try to create them, they’re larger than the template’s default indents. How do I format them so they match the chapters that were written directly into the template? I can’t find any way to format them uniformly. Would it be better to have no indents at all throughout and just format them all in compile later? I’m still learning the ins and outs of Scrivener. Any assistance would be appreciated.

Select the problem document(s), and then go to Documents->Convert->Formatting to default text style.

That should fix it. In the future, you might consider using File->Paste and Match Style, if you are going to paste in text; it’ll preserve bold, underline, and italics, but otherwise will match the font, indentation, and other attributes of the project.

Hi -

I read the above messages with interest. I’ve literally just started moving all my old .pages (converted to .rtf) files into Scrivener, the novel template. The novel is around 240,000 words in 31 chapters. I’m trying to cheat and import stuff into my exact Scrivener formatting settings without reading every single line and correcting all the formatting by hand.

I can go for plan A: ‘paste and match style’, which gives me the left indent I want (0.25in for a new line) and does NOT give me an extra blank line (is this called a ‘double carriage return’?) after every paragraph, but LOSES all my italicised words \ phrases \ sentences (there are quite a lot, as there are alien languages involved).
I can go for plan B: paste as-is, which keeps all my italics, but has my left indent come out at 0.25in PLUS the text’s original 0.25in, which is impossible to fix except going to each new line by hand and deleting the ‘extra’ tab space that does not show up on the upper ruler (but doing this makes all the text left align at 0 and puts an extra blank line after every paragraph, which I must delete one by one).

(I’ve tried opening the original .rtf file and trying to eliminate the indent for the first paragraph there before importing it into Scrivener, but there isn’t a tab stop there, so again, there’s nothing to adjust via the top ruler. I can have it at an invisible stop of 0.25in with no extra line between paragraphs, or I can have it aligned at 0in but have extra lines between paragraphs.)

To be clear: I’m lazy. All I want to do is find a way to paste all the text into a novel preset, so that I keep all the italicised text, remove the extra left align tab stop so it only obeys the single 0.25in tab stop in the new novel document, and NOT have any extra empty lines after every paragraph. --Without going through deleting the extra line or the tab stop by hand, because it doesn’t ‘exist’ on the top line of the Scrivener ruler.

Any ideas? I’ve been going round in circles reading the manual and trying new paragraph presets, converting documents to defaults, and ending up with a complete mess of duplicate files in case I can’t undo the formatting I try. If it can’t be done, then fair enough. But if someone knows how to achieve this miracle, could you please let me know? I’ve got four more books, around 200,000 words each, that also need importing to Scrivener, and I would like to avoid RSI from pressing ‘down’ ‘left’ ‘delete’ over and over.

Apologies if I’ve missed something really basic here; I’m still getting to grips with the software (which is great, by the way) and the manual. Ta for reading this essay. Hope you’re all getting your writing done!

Happy scribbling.

Briefly, I had a similar problem. My default text style preset was set for 0.25" indent, 1.2 line spacing, with 9 pts paragraph spacing. I’d import an rtf file, apply the preset format, and lose all my typographic markup … italic, bold, etc.

UNTIL the happy day I decided to test the effect of the four check option boxes in the panel: [Documents] -> [Convert] -> [Formatting to Default Text Style…] opens a panel called “Convert Format” with five option check boxes. I UNchecked all of them, and found that my default text styles were properly applied, AND all of my italic, bold, etc. inline formatting was preserved. I’ve been a happy camper ever since.

(I don’t bother with the “paste and match styles” … I just do an .rtf import, or a direct paste. Then I apply the Convert menu. The document styling is converted without unwanted formatting destruction. Hope this helps.

Thanks for the fast reply, Graybyrd! Unfortunately, when I tried it, I still get the text formatted at 0in and a new line after every single paragraph.

I should stop being so lazy and just go through it all line by line. Or I could stop being so picky and just override it all in the ‘compile’ settings. If I find a way to do that. But that’s another post for another day.

Thanks for your help, though. :smiley:

Typically, the indents, font and other settings are overridden during compilation by Scrivener by default, unless you tell it not to; this allows you to output vastly different formats from the same source without changing anything in your project. Try doing a test compile, and see if the indents persist.

As for it adding newlines; are they really empty lines? Can you put your cursor on those empty lines? It could be that paragraph spacing is set strangely, giving you double-spacing between paragraphs while only having a single paragraph marker.

It’s very strange that Paste and Match Style is obliterating your italics… are the italics the same font as the non-italics? It’s possible that by using word styles, you’ve got passages that are in a font that just looks italic, but that’s it’s “standard” typeface. Otherwise, I’m stumped on this issue.

Paste & match style has always stripped formatting from pasted text, in every app I’ve used it in including Scrivener (I double checked* after reading this thread to make sure). It has always been my understanding that this command pastes the text in the clipboard as plain text in order that it will take on the formatting of the pasted location. This is, to my mind, the purpose of the command.

The extra lines between paragraphs could be removed by search and replace all - but it is worth checking if they are two paragraph breaks or a combo of paragraph and line break. Use Format > Options > Show invisibles to see.


That’s what I thought too. It’s why I didn’t try paste and match style the first time, as, like you say, it wipes the formatting and makes it match what the page is set to. Glad I was right about that! I just pick things up as I go, and sometimes I misunderstand it but over time my misunderstanding becomes my personal canon. :smiley:

There is definitely an entire blank line between paragraphs, and not just ‘double’ formatting or something else (thanks Graybyrd for that suggestion. :slight_smile: ) But a combo? I had no idea. When I get back from work sometime in the future I’ll check it. Thanks! And a way to show the invisibles and get rid of them? Genius. Thank you! Can’t wait to try it out.


Using Documents > Convert > Formatting to Default Text Style won’t strip character formatting like italic, bold, etc. unless the font you are converting to (i.e. the one set as the default font) does not have a bold or italic variant. None of the options in that panel affect this, so I’m not sure what you might have been doing that caused a change unless you had switched something else as well in the meantime.

However, applying a preset is different. Presets (from the format bar or Format > Formatting > Apply Preset) are just saved formatting, and if the character formatting is saved, that specific formatting will override whatever you’re applying it to. So if you’ve saved a preset with “regular” text (no italic, no bold) and have saved the character attributes, then whenever you apply that to a selection of text it will wipe the existing character attributes and replace them with the preset’s.

The tab stop is immaterial, really; what you don’t want are the tab characters. So you can just remove these by loading the whole set of documents as a Scrivenings session and using Edit > Find > Find… and leaving the Replace field blank (use Opt-Tab to add a tab character to the Find field). Then adjust the first-line indent by selecting all the text and dragging the rectangular bar in the ruler to the .25 mark or just using Documents > Convert > Formatting to Default Text Style, assuming that the first-line indent is set there how you want it. (It is set to .5" out of the box, but you may have changed it.)