Numbering chapters and subchapters

I read the manual, but I can’t find how to do the following thing:

I have several chapters, the first ones I want to numerate as I, II, III, IV
Then, I have other chapters which want to number as 1, 2, 3, 4, 5. Each chapter has a subfolder and what those subfolders being numbered as 1.1 1.2 1.3 1.4 en their subsubchapters as 1.1.1 1.1.2 1.1.3 and so on. I’m writing a PhD thesis, so this is extremely important.
All I got reseting were wrong numberings.

Chapter I
Chapter II
Chapter 1 Title
1.1 title
1.2 title
1.2.1 title
1.3
1.3.1
1.3.2

Chapter 2 Title
Chapter 3 Title
3.1 title
3.2 title

And all I get is:
Chapter 1 Title
1.1 title
1.2 title
1.1.1 title
1.3
1.1.1
1.1.2

Chapter 4 Title
Chapter 5 Title
5.1 title
5.2 title

I want this:

And how to number the first pages as I, II, III, IV, V… and then 1,2,3,4…?? as seen in the table of contents?

Hi spin_echo, as usual there are probably several ways to skin this cat. First off you have to make sure your binder / outline levels are as you want, and try and think of each Level as a “thing” you want (Section, Chapter, part, subpart etc.)

  1. Easy Version: To have some Level 1 Roman numeral chapters make these compile “AS IS” and put the Title in the text. Then for the remaining Levels just use <$hn> for all numbering, this will get you 1, 1.1, 2.1.2 etc. without much effort, but will break if you move things around too much.
  2. More complex: Read Help > Placeholder Tags List…, this tells you the tags you will need if you want more complex numbering and mixes. In general you want to create number counters for each “thing” like <$n:section>, <$n:part>. For each Level in the Compile > Formatting you will edit Section Layout… prefix and suffix as needed (or edit the Binder titles but this looks a bit messier IMO). To reset a counter you use <$rst_section>, <$rst_part> etc. Other useful tags are <$position> and <$parent_position>

Regarding the page numbering, you need to see Compile > Page Settings… > First Pages and you can use <$p-r> for roman page numbers and tweak the page start. If you have a front matter it will get the first page settings.

BUT: your screenshot is showing a TOC which is something normally generated after compiling. Scrivener is not a full layout system and you may be better served doing the layout post-compile (the screenshot is the Scrivener manual which I think uses LaTeX). For a very large academic project report I used proper outlining from Scrivener (I use MMD which generates Level 1 - 6 properly), and then LibreOffice to deal with TOC, page numbering etc. As you will have a bibliography to generate I don’t think you can use Scrivener to generate the final document as you’d have to do referencing manually which IMO is crazy… :stuck_out_tongue:

Thank you very much for the answer.
I think that I was doing it wrong, I tried to reset but I couldn’t find the proper way to apply it. Thank you for the big help!

The TOC I put is the one from the Scrivener manual. So I guess it was generated with LaTeX.

Thank you for this post (and the response!). I had not been able to determine how to insert roman numeral page numbers into the first pages/front matter section until reading this thread. I now have that issue resolved, but I still cannot figure out how to remove the roman numerals on the title and copyright pages and still have them counted; in other words, how can I make the Abstract page be the first to display a page number as “iii”? The option of not printing the page numbers on single pages (where page breaks at the beginning and end create a single page) won’t solve the issue, as both my abstract and acknowledgments sections will be on single pages.

My front matter section as I want it:

Title page (no page number)
Copyright page (no page number)
Abstract (iii)
Acknowledgments (iv)
Table of Contents (v-vi)

Thanks for your help!