Numeric list type (1. 2. 3.) does not work.

Hello. I love Scrivener. It is the only thing that gives me a fighting chance. :laughing:

Mac OS X 10.12.4; early 2013 MBP 13"

First category in Lists (1. 2. 3.) does not work; initial ‘1.’ is applied but subsequent numbering fails.

Scrivener 3.01, (966) no updates available.

Using Bookerly font.

Type first list item; choose first numeric list type, hit return. ‘1.’ is applied.

Hit return again to enter second list item; list does not work, i.e., ‘2,’ is not applied, hit return again, not applied.

If I use the second type of numeric list { 1) 2) 3) } it works. Both types work in TextEdit.

Thanks for Scrivener.


Thanks for the kind words - glad Scrivener is proving helpful!

I’m afraid I can’t reproduce this at all, though. I tried downloading the Bookerly font and following your instructions, but everything worked fine. The way bullets are applied and work are entirely down to Apple’s text system, so I’m not sure how something like this could be caused (that’s not to say that Scrivener couldn’t interfere somehow). Are you using styles or anything else? Perhaps you could upload a sample project showing the issue (zipped up)?

Thanks and all the best,

Thanks for reply, Keith. I’m very ignorant about fonts and formatting and rational expectations for behavior of the software. So much so that I’m not sure even how to ask the right questions.

Example: in iOS I thought that one chose the list type and then typed but it seems to be the reverse, type first item and then choose list. Seems also that you can’t “manually” go in and delete returns and list items expecting renumbering to work.

Anyway, I will keep messing with it and muddle through, coming back here if I think I can add anything.