Odd behaviour of Paste

Having observed odd Paste behaviour I tried the following sequence:

  1. Shut down MB Air
  2. Start MB Air
  3. Start Scrivener - opens current project correctly
  4. Ctrl V - nothing (as expected)
  5. Select 1 word (‘VERSION’)
  6. Ctrl X - ‘VERSION’ removed
  7. Ctrl V - Pastes more or less a page of formatted text (from the project but not ‘VERSION’)
  8. Ctrl Z - Paste successfully undone
  9. Shift / Alt / Cmd V - ‘VERSION’ successfully pasted

Any ideas please?

Ted Davison

When you say “ctrl”, do you mean “cmd”? “cmd-C” and “cmd-X” are the cut and copy shortcuts on the Mac; the shortcuts you described except for in the last step are the Windows shortcuts - could this be what is throwing you?
All the best,

That’s very interesting; never seen or heard of anything quite like it. Have you tried pasting into other applications after step seven is confirmed? TextEdit would be a good candidate, as it has a Paste And Match Style command as well. It could potentially confirm that Scrivener is doing something weird with the pasteboard insertion itself, and that the bug isn’t happening after that point.

Where is the pasted text coming from, another document in the Binder entirely? One other question, I’m sure it was just a typo, but you used “Ctrl” in all of your examples rather than “Cmd”. Are you using some kind of clipboard manager with alternate keystrokes? Because by default, Ctrl-X will do nothing at all (and Ctrl-V drops the cursor to the very bottom of the document). Some applications, like QuickSilver and LaunchBar, come with clipboard managers switched on by default. I’ve had some weird results with those turned on, most likely because I’ve never read the documentation (prefer PTH Pasteboard Pro).

Thanks for usual swift responses.

First, the nonsense - yes, I did mean Cmd.

Update - more bizarre still. The problem is now coming and going with no discernible pattern. At present it’s gone so the ‘other app.’ idea - thanks Amber - can’t be be tried. Will advise.

It is noticeable, and especially odd, that when the problem is present, the pasted text seems always to be the same even after an overnight shutdown of the machine. Seems this piece of text is stuck in a (legitimate or not) buffer somewhere…

Ted Davison

Stop Press

The problem has reappeared.

Cmd + V now inserts the spurious text in Scrivener but the correct text in Textedit and MSWord and, incidentally, in this window: 'He rose behind his desk to greet her, '.

Shift/Alt/Cmd + V inserts the correct text in Scrivener and Textedit but (rightly) does nothing in MSWord.

Ted Davison

Could you please post necessary steps to reproduce? Does this happen every time with this same piece of text? If so, in which program is the text you are copying contained? Could you please give exact instructions on how I can see this same behaviour for myself - until I can reproduce it my end, there is very little I can do, I’m afraid, and I’ve never seen this behaviour.


On closer examination, it seems what is happening is that Cmd + V pastes the buffer text correctly but applies bullet formatting to some half-dozen paras before and after the insertion point.

To try to answer your specific questions…

When it happens, unpredictably as I have said, it happens whatever the text in the buffer. This text is always cut or copied from within the same Scrivener project as I’m pasting to, not froman external source.

If you need more, I’ll need to extract some stuff from the project (the whole thing is some 60 MB) and see if I can reproduce it under those conditions then send you the whole sub-section.

Ted Davison
+44 7710 045868

When you create a new document, does it add bullet points when you begin to type? I am wondering if you have accidentally assigned bullets to the default paragraph formatting in the Text Editing preferences - could that be the case at all?

Afraid not Keith. Tried a new project - new para has no bullets.

Checked Prefs - not exactly sure where this would be set but couldn’t find it and anyway my new paras in the existing project aren’t bulleted.

Ted Davison
+44 7710 045868

Something unique is clearly going on your end, or I would be inundated with reports like this, so I need to see it, I’m afraid. Are you seeing the same behaviour in new projects? Does it happen with any text pasted in? If so, first try saving your preferences (via the “Manage…” button at the bottom of the Preferences panel) and sending me the saved preferences file.


  1. Stripped down version (SDV) of my project
  2. Saved preferences [Previewing shows this not attached - can’t figure why. Will send later if needed]

I did the following:

  1. Shut down MacBook Air
  2. Restart MBA
  3. Dbl Click thumb of SDV - opens in Scrivener
  4. Cmd + V - nothing (as expected)
  5. Select one word (‘cooled’)
  6. Cmd + C
  7. Insertion point to blank line above
  8. Cmd + V - inserts ‘cooled’ as bulleted para
  9. Cmd + Z
  10. Shift/Alt/Cmd +V - inserts ‘cooled’ sans bullet

Ted Davison
+44 7710 045868
Al in Vietnam 8 copy.scriv.zip (81.4 KB)

I can confirm that this is definitely something going on your end, as I followed your instructions and everything worked perfectly fine for me (no bullets either way I paste).

Do you have any extra text services installed?

All the best,

Wait, I can reproduce this using the sample project. I double-clicked on the word “crowd” from the paragraph above the empty line, placed the cursor on the line by clicking in the white area to the right of it, pressed Cmd-V and got a square style bullet along with the word “crowd”. Cmd-Z and Paste Match Style did a normal paste. Bullet does not appear when pasted into TextEdit, and examination of the raw pasteboard reveals nothing out of the ordinary.

It only happens in that one blank line though. Pasting anywhere else is as expected. Examination of the Ruler setting on that line shows that Lists have been set. In other words, this particular case is not a bug as if you have a paragraph set to list mode and paste something into it, it will become a list. What is curious is how it got that way, which is where the odd behaviour really is. I attempted to insert blank lines in several other positions of the document and got ordinary paragraphs and successful pastes.

(Also strange is that you didn’t get a bullet, Keith. When you position the cursor on the line and check the list drop-down, is it set to None?)

If you can create a replication scenario that extends earlier back in the process, to the creation of that phantom list line, that might help.

Ah, yes, I got it to happen. Very strange! Unfortunately it seems to be nothing to do with Scrivener but the text system, though - I copied and pasted the whole text into TextEdit then did exactly the same thing, copied the word “crowd” and pasted it into the empty line, and got the same effect in TextEdit.

However, I was able to fix the odd behaviour like this:

• Select all the text.
• From the “List” pop-up in the ruler, select “None”. (Notice how the line spacing changes slightly, indicating that there was some weird list setting in this text.)

Now everything works as normal. My guess is that you used bullets at some point in composing this text, and that OS X’s rather rubbish bullet implementation didn’t clear the underlying bullet formatting when you deleted the bullets.

Hope that helps.
All the best,

How extraordinary to have such support from London (England) to Portland.

Too late for me to follow up your latest tonight (WSC’s ‘Second World War’ beckons).

Will investigate further tomorrow.

Thanks and good night

Ted Davison
+44 7710 045868

Keith / Amber

Yes, that seems to be the problem. Only certain chapters show this behaviour and it goes when the List… command is used as you describe.


Ted Davison
+44 7710 045868
PS Can’t really blame Steve, he’s not been well recently.