Odd new 'Background Shape' in Scrivener

EDIT: After writing this I discovered that this problem is affecting all of my writing apps (U3 and Drafts) and other aspects of the GUI. Still - any ideas to try very very welcome!

This is a Scrivener problem - despite the Scapple terminology …
An odd problem starting today: when I select an item in the Binder, a ‘background shape’ is added to the whole binder and I am unable to navigate to the next item using arrow keys - although the next item is highlighted, the Editor does not change. (The Editor has not been accidentally locked). When I move the focus to the main editor a new ‘background shape’ in then added to that. All very odd. I have restarted the programme (3.3.6), re-booted the Mac (13.6.3) and changed themes.

It’s impossible to work like this so I hope it’s something simple …

Thanks

Does this affect only the one project? Or, are you seeing this issue in multiple projects?

If you only have the one project, you can open the Interactive Tutorial from Scrivener’s Help menu and test how it behaves. When you first open the Tutorial, Scrivener will prompt you to name it and select a save location for it.

You can then try navigating in that project’s binder and add a document to it.

If these issues occur in both your working project and the Tutorial or in a few Scrivener projects, I recommend that you reset Scrivener’s preferences to see if that corrects this.

If these issues are only occurring in the one Scrivener project, you could reset the project display settings for that project, which could resolve this issue.

If it’s affecting applications other than Scrivener, it’s a Mac OS issue.

Could you post a screenshot? (I’ll check your trust settings to make sure you can.)

Yes - very definitely a Mac issue - it affects every aspect of use: I’m just hoping someone in the community might have experienced the same. Interestingly the colour of the ‘background shape’ follows the Highlight colour choice in Mac OS system settings.
I’ll take a screenshot now.

Two screen shots: 1 - Binder item selected and down arrow key used to try to select next Binder item (which it doesn’t it simply highlights it); 2 - original binder item selected and loaded to Editor then selected (adding the border) for editing.


Rather larger screenshots might be a tad more useful:


Check your Mac’s Accessibility settings. I’m not sure exactly what it would be – and I have a different version of Mac OS – but this looks like a “lock display so motor control issues won’t mess it up” kind of setting.

The border is a “feature” of Sonoma’s Full Keyboard Access, which you can toggle under  ▸ Settings ▸ Accessibility ▸ Keyboard. If you want to keep the full keyboard access but are driven batty by the border, click the circled “i” button to the right of the toggle and you can adjust the border colour and timing to minimize its appearance. I’m a fan of auto-hide with .01 second delay. :wink:

Thanks Katherine, Jennifer - I’ve tried the accessibility settings (all of them on and off) and it makes no difference. The issue is not so much the border itself as the restriction of function: before I could use the arrow keys to move up and down in the binder and the editor would follow, now the keys just highlight the next item but the Editor focus remains on the first selected. Oddly enough, Tinderbox is alone in my text apps which is unaffected by this.
I’m on an iMac running Ventura - the latest possible for this model - but there’s been no issue like this before, in the last three weeks since the Applestore installed the OS. So I must have done something to upset it - but I can’t imagine what.
I can still write - but it’s a workflow pain to have to mouse click to select the next Binder item (one of the many reasons I found Obsidian irritating).

Thanks again - I’ll have to find a way of describing the issue for the Apple support chat.

That’s very odd, as it really does sound like the full keyboard access. When that is enabled, commands like up/down/right/left do work differently. This is under Sonoma, so perhaps it’s different under Ventura, but you could try using the arrow up/down keys in the binder and then space bar to “Activate” the selection and load the item.

Jennifer - you’re absolutely right. I tried first the route of minimising the appearance of the border, but that didn’t help the navigation problem (nor did using the Access key-strokes). But I have now turned off Full Keyboard Access completely - and all is well again. (I don’t ever remember turning it on - maybe an end of week senior moment).

I will never doubt you again.

Oh good, I’m glad you’ve got it all back to working!

Perhaps it was the cat.

(“But I don’t have a cat!” you may protest. No matter. Somewhere, there is a cat. And that cat is devious.)

2 Likes

I don’t have a cat, but I do have two devious, dexterous, delightful Deerhounds …