Only the first page of PDF's appear after update

After installing Scrivener 2.0, I opened a Sriv 1.54 project, it asks to update the project and opened nicely. But when I checked the PDF’s that had been in the original, the 2.0 version only had the first page of the PDF’s.

I tried this by creating a new test project in 1.54 and the same thing happened when I opened it into 2.0.

I tried “View/Media/PDF Display” but it was greyed out.

I also tried to directly import a multi-page pdf into my new 2.0 project, and it worked fine, displaying all pages.

I’m testing from copies until I know it’s safe to shift over my work, because I have a lot of media/PDF’s etc in my project. Has anybody else had this issue?

Presumably you mean PDF files embedded in the text? Scrivener 2.0 uses the RTF format internally rather than RTFD format, so this is a new limitation - PDF files in the text will be converted to regular images, which will generally be the first page.

But why would you want multiple-page PDF files in the text anyway? These cannot be exported to any meaningful format. When you print your work or export it to Word or almost any other format, the PDF file would be compressed into an image showing only the first page.

Note that everything above refers only to PDF files embedded in the text. And PDF files embedded in the text should really only be regular images. Nothing has changed regarding viewing PDF files as research - Scrivener 2.0 still fully supports the viewing of multi-page PDF files, of course.

It sounds to me as though in 1.x you may have dragged PDF files into the text area when you meant to drag them into the binder to refer to them as research. To fix this, open the back-up of your project in 1.54 (Scrivener will have made a backup in the old format in the same directly as your project file during the update process). Then go through the affected documents and drag the PDF files out of the text area and into the binder directly (the Research area, or anywhere except the Draft folder). Then update again.

All the best,

That is, I’m sure, exactly what happened. And now I know how to fix it!

I had noticed that some of the PDF’s behaved differently when I put them in 1.54. It must be I dragged some into the text, and some into the binder. I’ll sort that out and be off and running. Thank you.

And maybe if somebody else did the same thing, your answer could help them too.

I couldn’t get this to quite work.

I opened my 1.54 doc to a pdf that I had dragged into the text area of a file in the Draft folder. I dragged that pdf from the text area where it was displayed, down into the Research folder. They showed up fine, but still appeared in the 1.54 Research folder as a text file with a pdf inside. And when I updated the project to 2.0, they again showed only the first page in the new Research folder.

I did successfully drag an original pdf from the Finder into the 2.0 Research folder, and that showed up as a pdf, with multiple pages showing. Hmm. I’m not sure I can find originals of all the pdf’s I’ve mistakenly stored in the text areas.

It’s weird, because I can see the whole pdf in 1.54, displaying in the text area, but I can’t get it out to put in 2.0. (I guess that’s the new limitation you mentioned.)

The way I got into this mess is (clever me): I decided I wanted to organize pdf docs right near my text in the binder, so I cmd-n to create a new text file, then drag my pdf doc into that file, inside my draft folder. The whole pdf displays, and I can even type my own text notes around the pdf in the file as the pdf shows up as an element in the in-line text. (These notes around the pdf may be the handy thing that led me to do it.)

It displays like this when I do it in 2.0 as well, until I close the project, then it looses the additional pdf pages.

I’m not sure how I should have organized this in the past, but now I’m wondering how to bring those mis-organized pdf’s forward.

This is far from graceful, so there may be a better way to do it, but if you open the 1.54 project in Finder and “show package contents,” you can search for “pdf” and it will bring up all the pdfs in your project, including those that are packaged as attachments with the .rtfd files. (Basically, your pdf-in-text file is a .rtfd with the original pdf as an attachment, so if you find the right .rtfd file in the .scriv project you can “show package contents” and then save the .pdf from there; a search within the .scriv contents as a whole should pull it up regardless of where it is.) You can save them out from there and pull them in fresh to your 2.0 project. (Saving as an intermediate step is optional; you could just import them directly to the 2.0 project if you don’t need them elsewhere on your computer.)

That’s the best way I’ve found so far, but there may be a more elegant solution.

Hmm, what’s probably happening is that when you drag the PDF out of the text area, the standard text view is putting it on the pasteboard as RTFD rather than as a file, so that it just creates another text document in the binder (the same as text to the binder). That makes sense now that I think about it - sorry for steering you wrong.

Ugh… Unfortunately the only way I can find of doing it would take ages:

  1. Ctrl-click on the 1.x .scriv package in the Finder and select “Show Package Contents”.

  2. In list view sort by file size, with the biggest at the top.

  3. Go through the numbered RTFD files (don’t worry about the ones that say “_notes.rtfd” unless you have any PDF files in the notes area for any documents).

  4. For each RTFD file, ctrl-click on it and select “Show Package Contents”. The PDF files should be inside these RTFD files.

There must be an easier way of getting these files out Apple’s standard text view, but I can’t find it. It should be possible to write a script to do this, I wonder if another user has any suggestions for a quick automated way of doing it?

Curiously, while “show package details”-ing my .scrv file in the Finder and looking through the many .rtfd files. I can quicklook them before doing the “show package details” on each file individually, and see the document, with the inserted pdf scrollable within quicklook. This is quite handy for finding the ones I need to dig out.

I sorted by size and found about 20 large .rtfd files. Quicklook helped me eliminate some that only had a bunch of graphics (some of which might be one-page pdf’s but they should still work fine?) Leaving about ten files with multi-page imbedded pdf’s. That’s not so bad, even if I have to dig them out this way.

Now I should be able to drag those pdf’s from the finder back to my open Scrivener project into the Binder where they belong? Can they only go into the Research folder? Yup, only into Research.

I suspect that’s another reason I dragged them inside the text files originally; it wouldn’t let me put them into the draft folder otherwise. Some I actually have in Research and included in a piece of text. A lazy way to keep my reference material at hand mostly. I think 2.0 makes it easier to add internal links, so I shouldn’t miss this much.

If it wasn’t such a pain to deal with now, it was occasionally useful to have those full pdf’s available in the text. A few of the shorter ones (two page pdf’s) were to be included in the final printed document. I’m not sure how to deal with them in the future.

Are there ways to associate full pdf’s with parts of the Draft document? I can link in the text to pdf’s (or whatever) in the research folder, but will those print as part of a document? (I guess they wouldn’t have printed right before either?) It’s a research project, so the research is a bit mixed with the main document. I have a lot of other information only in the research folder that doesn’t get printed of course.

Sorry to take so much time on a problem few others may have been clever enough to dig themselves into!

The thing is that PDFs inside the text won’t get printed properly anyway, because they are included inside a scroll view, and they will never get treated properly by other programs you export to, either, so in many ways they are rather pointless - it’s always much better to keep your PDF files separately. They don’t have to go in the Research folder, by the way - you can create any folder to put them into, including other folders on the same level as the Research folder. You just can’t put them in the Draft folder, because that is for text documents only.

It’s not automated, but I’d venture to say the method I posted above is faster. :wink: If you just open up the .scriv package and then search in the Finder toolbar for “pdf” it will bring up all the pdfs in the package, including those hidden away in the RTFD attachments, so it saves the step of sorting through the RTFD files. You can just bring up all the pdfs and drag out the ones you need; those in attachments keep their original titles as well, so that combined with QuickLook should make it fairly easy to grab what you want.

You could probably make an AppleScript for it too, but honestly I don’t know how much work that would save since you probably still need to go in at some level on your own and make sure you have what you want.

I think I’ve got it sorted now. Thanks for your help!

I found it easier to option-click, “open package contents” and search my scrivener project by the size of the rtfd files, since only some of my many pdf’s were misplaced. (Searching a list of all/only the pdf’s might have taken more time.)

Whew. It’s so easy to do things wrong sometimes. Thanks for helping me correct myself.

It’s a bit confusing that I can still drag a pdf into the text and see and scroll through it, but then it doesn’t save or print. A notice saying, “Drag pdf’s directly to the Binder” might prevent others from repeating my error?

Yea! Off to 2.0. The new Link methods should make it much easier to link to pdf’s and whatnot now. Thanks for all.

Yeah, sorry, I didn’t mean to sound snotty about it. And I did think more on it after posting to consider that if you had a ton of pdfs “properly” placed directly in the Binder, then you might end up with more of a hassle. So what you do want then is a script to go through, pull all the pdfs that are filed in RTFD attachments (while ignoring those that are directly in the Binder) and collect all those for you to import. Perhaps it would be so fancy as to import them for you, hmmmmmm. :wink: Anyway, glad you got it worked out!