Open file, cannot move notes

I can add notes, but not move them once added. Nor can I move existing notes. I close the file, open it again and can magically move notes. Add a note, can no longer move notes. I’m not admin on the machine, and scapple (currently in the trial mode) is installed as local user. Was working last week, before system updates and patches (current windows patches for Windows 7).

If it helps for the devs, I can reproduce this every single time. Let me know if there’s some kind of log I can provide. Right now, scapple is no longer usable for me.

Have you updated Scapple? I used to have the same issue, but I haven’t with recent versions.

yes, it’s the latest version. It’s the windows patches that caused it, as it was working prior to patching. It’s now dead in the water. Breaks every time.

Looks like I won’t be buying this product. I reinstalled, moved files off dropbox. The thing is a turkey. I’m happy to provide any debug output because I’d like to use scapple, I can’t. It’s completely broken for me.

I know this is of no real use to you, but I’m also on windows 7 and did last Wednesdays updates without problems - I am the admin and have a registered copy though. I hate it when things like this happen, it’s easy to loose confidence, but I guess it’s still relatively early days - my version is 1.0.0.0! Hope someone officially responds and it gets it fixed for you soon. :neutral_face:

Just a long shot, but there’s an option to ‘Prevent Editing’ under the File menu, maybe try toggling it off and on to see if it clears things.

Thanks, I tried it but it didn’t work. I can add notes, I just can’t move any notes once I’ve done that. I can move notes at will, until I add a note. Happens consistently and repeatedly. Like I said, I can provide a debug if such an option exists, but there doesn’t seem to be an audience for such a thing. Oh well.

Maybe try emailing support directly: scapple@literatureandlatte.com

Have you tried moving notes with the keyboard? Use Alt-M to toggle keyboard movement on and then the arrow keys to move notes around. I offer this not as a suggested alternative way of working (that is better for minor adjustments than normal usage) but to see whether it is a problem with the pointer interface or not. Can you do anything else in Scapple that involves click-and-drag, like marquee selection or connecting one note to another?

Tested and confirmed, can move notes using Alt+M. I can do click and drag for marquee, but can’t test making connections, as I cannot move notes onto other notes.

Interesting, okay second question: are you using a standard plug-in mouse, or is it an embedded laptop pointing device, tablet or anything else of that nature? We are aware of a few rare hardware issues with some pointer drivers that are as yet unresolved.

USB mouse, plugged in.

So are we done here? Scapple doesn’t work and that’s it?

It is unfortunately looking that way, though I don’t know why. We did have some reports of click and drag issues when running the software through virtualisation software (basically, a way to use Windows programs when you aren’t using Windows), but that wouldn’t apply to you since you’re using a native Win 7 setup. The only other case where click and drag was an issue was when panning—holding down the spacebar and clicking and dragging to move the canvas around, or doing special connection drags. This was down to an overly aggressive trackpad function that ships with some laptops, where any key press disables the track pad making modifier drags like that impossible. Click and drag worked fine if a keyboard key wasn’t depressed. That doesn’t match what you’re describing either. I’ll see if someone with more knowledge of Windows can help out here.

Have you tried uninstalling Scapple, trashing the installation directory if it remains, rebooting Windows, and then reinstalling? It won’t affect your trial period, but it will ensure that your installation has all the libraries it ought to. If that doesn’t work, you could try rolling back to pre-Windows 7 updates, checking that Scapple works, and then reinstalling the critical updates. It could be they didn’t install properly, or there were problem ones on your particular setup, though I realise if nothing else is behaving oddly this may be a bigger chore than you want to try.

Bluetooth mouse, built in scratchpad mouse work. USB mouse does not. So I’m using a bluetooth mouse and Scapple is now usable.

Interesting! Could you tell us what what the precise model and brand of the USB mouse is? It should have that info on the bottom if it hasn’t scuffed off.

Dell M-UAV-DEL8, optical.