Open in Preview by default?

I compile a lot so that I can get a glimpse of how things are progressing with my document. Don’t know why, it probably doesn’t help, but that’s my habit, so… I prefer to have Scrivener compile to Preview as a ‘burner’ copy that I can take a quick look at and throw away immediately, but that doesn’t leave files all over the place in the process.

Is there a way to set my default Compile output option to “Open in Preview” so that I don’t have to bounce over and drop down the selection in the middle of the process?


If you Compile to PDF, rather than Print, there’s a “Open compiled document with” check box at the bottom of the file save dialog.


Of course that will create a (non-temporary) pdf file – which is not quite what the OP is dreaming of.

For my own case, I too often find myself compiling and recompiling to get thing just so or because of late edits. But my output files don’t mount up in this case since I compile to the desktop and use the same file name (namely, scivs default of the project title), so the prev file just gets replaced. In the end I will be renaming and keeping the sole output file that resukts – when I get done tweaking. No muss, no fuss!

Hi, John.

Not the solution you want, but creating an “Open in Preview” keyboard shortcut (used during compile) can speed things up a little and save unnecessary mouse travel / clicks.

Slàinte mhòr.

Given the convenience of the regular file-based compile options and the auto-open checkbox, consider an approach of making a special folder whose only purpose is to serve as a dumping ground for temporary compile files. It is the kind of thing you can just leave be and rarely even go into, and you can clean it out now and then without worrying about losing anything important.

Myself I tend to have one such folder for each major project, all located within a master “rendering_folder”. Nothing in there is essential or important to keep, but I tend to very rarely clean them, because there is no strong reason to. I will delete a project’s compile folder once it has been archived and I no longer need anything from it.

I do agree that the Print → Click PDF button → Select “Open in Preview” route is a bit awkward, but there isn’t much we can do about that. Once you get into that print settings dialogue box, you are technically in macOS territory, not Scrivener. If you look around, you will that is how all print dialogues work (outside of those completely bespoke interfaces from ported software).

Adding a keyboard shortcut speeds this up, especially for any user who runs compiles to Preview regularly. No need to click and select once the print dialogue is open.

Slàinte mhòr.


Awesome workaround Jo, and I can see plenty of other uses for that too! Thanks a bunch.


A pleasure, John.

Slàinte mhòr.


Try using a simple cmd-P for that shortcut. It will not trigger anything before the print dialog box comes up, so invoking print with cmd-P works normally. Then hitting cmd-P again will trigger the Open in Preview command. (I much more often use Save to PDF and have used this trick for that purpose.)


P.s. This trick stopped working after some OS update a while back, but I see that it is back to working again!

Hi, gr.

Even with my custom shortcut deleted, I can’t get CMD P to invoke Preview. I am calling up the compile interface, selecting compile for print, and then pressing CMD P when the print dialogue is open, but nothing happens. Am I missing a step or setting?

I have tried CMD P from the editor, but that only brings up the print dialogue (not the compiler, of course) and then a second press of CMD P does nothing.

Thanks in advance.

Slàinte mhòr.


Curious. This totally works for me with cmd-P set as the shortcut when it is invoked when the print dialog is up – whether that is after cmd-P from the editor or from compiling to Print.

Different OSes maybe?

My OS: High Sierra.
Shortcut cmd-P set (under All Applications) to ‘Open in Preview’.

Embarrassingly dense on my part. I misunderstood your first post, assuming that CMD P worked as a default for “Open in Preview”. I entirely missed the fact that I needed to assign the shortcut.

Thanks for clarifying. Apologies for wasting your time. I should read things more carefully and not make assumptions.

Slàinte mhòr.

Ah, yes I guess I didn’t actually state the (modest) point of my suggestion, namely to economize on key commands.