Opening Links from Inspector

I have many documents with links. Usually, I see the file in the main editor, and in the Inspector under Document Bookmark, I can see the file to which the inspector document is linked (which is perfect). The problem I am encountering is opening links that are in the document showing in the Inspector. I can right click on the link and choose Open Link in Quick Reference Panel. However, nothing happens after I click there. Can you please offer suggestions on how to open these links?

Could you perhaps break down what it is you are trying to do in a series of steps? It is unclear to me whether I should be right-clicking in the Document Bookmarks list in the inspector, or in the main editor. The wording of the command itself suggests the latter, but both work fine for me, so I’m not sure what to try, or where I should be looking.

Hi Amber. Yes, it is about the document in the inspector. Here are the steps I am using.

  1. The bottom editor is locked and shows any file.

  2. From the binder click on a file (but not any file; it has to have links to other files) > the file shows in the top editor > lock the top editor.

  3. Click anywhere on the file in the top editor > in the inspector under bookmarks, I can see the documents/ files to which the file is linked. The file in the inspector has links too which is the file I have a question about.

  4. In the file in the inspector (which is visible when choosing Document Bookmarks), I can see a document that has its own links. These are the links that do not work when I click on them.

  5. Click on any of the links in the document in the inspector

    scenario 1: if the bottom editor were unlocked, sometimes the links from the document that shows in the inspector opens in the unlocked bottom editor. Today this was possible, but it does not always work.
    scenario 2: if the bottom and top editors were locked, I would like to be able to click on the links in the document showing in the Inspector (under Document Bookmarks) and to have them open in the Quick Reference Panel. Yesterday, they were not opening. My procedure to open the links there is: hover the cursor on top of the link + click control > the menu appears from where I can choose Open Link in Quick Reference Panel > I click on that option, but only hear a chime; the link is not opening in a Quick Reference Panel.

I am attaching a screen shot showing how my Behavior preferences are setup. May be I need to adjust something there. Ideally I would like to be able to open the links from the Inspector Bookmark document in a Quick Reference Panel.

I hope this is clearer. If not, I can make a short video but would not want to post it in the forum. And thank you for reading all this!
Screen Shot 2021-05-21 at 10.06.58 AM

Okay! Yes, the editor locking was the crucial ingredient to understanding what is going on. For reasons I don’t fully understand, when links or bookmarks are activated in the inspector, and the default behaviour would have that link opened in an editor that is locked, the operation fails silently. It’s maybe the only place in the software that works this way. I raised it as inconsistent behaviour some time ago, but was informed it is working precisely as intended. :thinking:

As for this specifically:

scenario 1: if the bottom editor were unlocked, sometimes the links from the document that shows in the inspector opens in the unlocked bottom editor. Today this was possible, but it does not always work.

It should just work if the conditions allow for it. I’d keep an eye out on that one and see if there are any other conditions involved in causing it to fail.

Thank you for looking into it. I hope there will be an option to open the Inspector Document Links in a Quick Reference panel too.

The bookmark preview area is treated as an editor for most purposes, so you can expect it to follow the same rules as the settings for clicking on links normally (same as would happen in copyholders, for instance). It’s just that in this case, very specifically, it doesn’t act like an editor (which would fall back to Quick Reference if default clicks go to the other editor and it is locked) and instead acts like a bookmark activation (does nothing).

That is a good clarification that only the links to do not work in the the bookmark preview.

I just want to clarify if the Open in Quick Reference is expected to work because for me it does not.

Quite right, I’d forgotten about that particular facet.

That is almost certainly a bug. I get a system beep when trying, and I don’t see any reason why that would be blocked.

That is good to know.

Do I need to submit a bug report about it?

Nope! Sorry for the lack of clarity, I’ve already got it written up for you. :slight_smile:

1 Like