Opening projects and files from within Scrivener

Recently I’ve begun having problems with Scrivener 3.

I deleted it and downloaded a fresh copy and that didn’t change anything.

For a long time I’ve been having issues with Scrivener sometimes freezing so that I have to close and reboot the app. Since I have always been able to do that, I haven’t worried a lot about it.

Now I have a new problem that may/may not be related.

I am unable to open projects from within the program. Nothing happens.

If I go through Finder to open, it opens.

I would like to do away with both issues, but even more, I want to be sure this isn’t indicated a bigger problem.

Anybody got ideas? Thanks in advance.

I would start by going, with Scrivener closed, to your Library folder — in Finder hold down the Opt key and click on the “Go” menu and Library will be listed in the menu — then choose Preferences scroll down and move the com.literatureandlatte.scrivener3.plist file and any other files with scrivener in the name —if there are any — onto your desktop. When you’ve done that, try opening Scrivener — which will build a new Preference file — and then your project(s). If that works, you’ll have to reset all your preferences. If it doesn’t, delete the new Preference file and drag the old one back into Library > Preferences.

The next thing to try is then in Finder, again with Scrivener closed, right click (Control-click) on your project and choose “Show package contents”; then choose Settings and move ui.plist on to the desktop (Don’t close that Finder window in case you need to move it back), then try opening the project with Scrivener. Again, if that works, you’ll need to reset all your project settings; if it doesn’t, delete the new file of that name and move it back.

At that point, with any luck, one of the Support team will have picked this thread up, otherwise contact them directly through,com.

Good luck.


Thanks so much!

Moving the files you suggested to the desktop worked!

Now, how do I reset all my preferences?

Again–thanks so much!

You have to go to Scrinener > Preferences and go through them all, and the included panes, for instance in Editing, and just reset them the way you like, I’m afraid. When you’ve done it, click the drop down in the bottom left hand corner and choose “Save Preferences to File…” and put it in a safe place where you can find it. Then if this happens again, or if you get a new Mac, you can from the same drop down choose “Load Preferences from File…”, which cuts out the need to redo it all again.



Edited once for typos

Thank you for the explanation. I thought maybe there was something else I was missing!

A followup question–when I open files now it takes so long for them to open that I’m wondering if the file is opening or not.

I haven’t timed it. I just know how long it generally takes and that it’s taking much longer comparatively. I just want to be sure there isn’t something else still going on I need to look at.