Option "Enter creates new notes" not working properly

It seemed to me, that this option worked for a different map I tried it on before. Anyway, is it a global option or per file?


  • Options > Tick “enter creates new notes”, leave enter ends editing unchecked
  • Edit note, type text, press Enter
    Expected outcome: Should create new note.
    Observed outcome: creates newline within note
  • go back to option: “enter creates new note” is unchecked

I’m also confused by this, although that’s nothing new! :confused:

The attached diagram (made in Scapple of course) is my thinking (imho) how it works.

The problems I have found are:

  • When you select the option ‘Enter creates new notes’, the selected option is not shown as being selected in the options menu. The option still works though.
  • If you select just the option ‘Enter ends editing’, the options menu then shows both options selected.

Thanks guys, I’ve got this on the bug list. It looks like it is working properly until you return to the options, at which point both Enter behaviours are selected or deselected based on the one you’d actually chosen, as Jono discovered.

The behaviour here is as Jono diagrammed, and I believe the problem gab is seeing is stemming from being in editing mode–“Enter creates new notes” applies when a note is selected or when there is no selection, but not when in text editing mode. There, Enter will either function to insert a new line or will end editing, the same as pressing Escape, depending on whether “Enter ends editing” is selected.

If “Enter creates new notes” is not selected, then (outside of text mode) when there is no selection or a shape selected it does nothing and when there is a note selected, it toggles into editing mode, like pressing Escape. Ctrl+Enter will always create a new note.