Option to turn off search-as-you-type?

I have a huge Scrivener project, and everything works very well except for project search.

Because Scrivener searches as I type, the first letter that I type is found in every document and things freeze for a moment while the list of documents is updated. The same thing happens on the second letter I type, and so on.

It makes project search frustrating, and borderline unusable… I have to copy and paste my search term to the search field.

Is there an option to turn off search-as-you-type, so that Scrivener will wait for me to enter the whole of the search term and press Enter before searching?

Or at least wait until you’ve typed a minimum number of characters, say 3?

I don’t think it would work to wait for 3 characters to be typed … it would be confusing for people who need to search for a 2 or 3 character word.

If there is no way to do this currently, I’ll turn this into a feature request unless people can see a problem with it…