Orphan text elements in Scriptwriting mode

Hi there,

With the current settings, Scrivener seems to be avoiding orphaning DIALOGUE from CHARACTER (although I’m not sure how, as I haven’t written anything into the fields shown below). Anyway, I’ve created two script elements, PARENTHETICAL and LYRICS. Is there way to avoid orphaning all three so a character name never appears at the end of a page by itself, regardless of what comes after it?

Similarly, is there a way to avoid orphaning titles of subdocuments? Research keeps pointing me toward the “Paragraph–>Keep With Next” option, but that’s already selected, and seems to be unrelated to both Scriptwriting mode and compiling besides.

Thanks in advance. I know it’s all there, but would greatly appreciate some navigation. Y’all are rockstars.

Wanted to update, as I now know that the default options will automatically keep “Character” and “Dialogue” together (as long as the script elements are named as such.) Is there a way to add “Character” and “Lyric” as elements that stay together as well?

Similarly, is there a way to ensure that a subdocument header starts after a page break if it will be orphaned on the page before?

thanks so much!