Outliner Columns - Notes

Is there a reason “Notes” isn’t offered as a column in the Outliner? Or is it and I’m missing it? Instead I can create a Metadata category called “Notes” and have it on screen but if I compile for printing then I get all the other Metadata too (instead of selected Metadata).

I.e., I’d like to include Notes and selected metadata in both the outliner on screen and in the Compile. What am I missing?

Just another user here, but I can offer an explanation of why Inspector notes can’t be displayed in the outliner.

Inspector document notes are rich text, i.e. they can have bold, italics, underlines, display tables, etc. The outliner, OTOH, can only display plain text. It would be a major effort to display rich text in the outliner, so I won’t hold my breath waiting for Inspector document notes to be displayed there. :wink:

As for the ability to only display some metadata in compile, I’d certainly welcome that! In the meantime, I’ve found two features to be useful.

First, I set up my outliner with all and only the columns I want to output. Then, I can either:

  • Use File->Print Current Document… to print to PDF, or
  • Use File->Export->Outliner contents as CSV… to get my outline into a spreadsheet where I can use full-up spreadsheet tools to format and output it.

Hope this helps!

Thanks for explanation of rich text re notes. Your two ways are the best. I’ve tried the printing to PDF but I only get title and synopsis no matter what I’m showing in the Outliner itself? Am I not checking some box. And I’ve used export to CSV and I think that is the best solution for what I want but it’s not working for me these days (it has before) I have the latest version so not sure what that is, but I’ve spent too much time screwing around and not enough writing!! So I’ll return to the online later. Thanks for your help.

BTW: There are also some options using compile but, again, gonna take more research.

You’re right! Curses! I hadn’t tried this in so long I’d forgotten. I should have known there was some reason I always compiled or exported to CSV that I’d forgotten. :disappointed:

I don’t have a clue on export to CSV not working, as it worked for me a couple of days ago. I totally understand that actually churning out words takes precedence. Happy writing!

Actually, yes. I’ve found some help. Try File->Page Setup… . In the dialog box, choose Scrivener from the topmost dropdown menu. Then click on the Outlines button. You’ll be able to pick and choose among the standard metadata. It looks like Custom Metadata only comes as a single block though. It’s something for you to try when you have a break, anyway. :smiley:
Screen Shot 2021-08-07 at 18.07.25

You can use the <$custom:…> placeholder to insert individual custom metadata fields via the Compile command. It works the same way as placeholders for built-in fields like <$keywords>. See the Placeholder list on the Help menu.