Output differences between print and PDF

When attempting to print out a chapter of my manuscript, I’ve encountered a problem with the output that’s requiring me to create a PDF and print that rather than print directly. The details:

  • Select “File->Compile”
  • In the Compile dialogue, place “<$sectiontitle>” in the header so I get chapter folder names printed at the top and leave “<$p>” in the footer for page numbers at the bottom
  • Click the “Compile” button

This brings up the small preview of the print out and allows me to either print or save as a PDF. Here’s where the difference comes in:

  • If I select “Print”, when the document prints the header prints but there’s no footer (possibly no room for the footer as the last line of text is printed quite close to the bottom of the page)

  • If I select “Save as PDF” the resulting PDF looks correct in Preview, and when I print from Preview the headers and footers are both shown

One obvious difference looking at the two print outs is that the text is slightly larger when I print directly from Scrivener and slightly smaller when printing from Preview. I get the same results when printing to a Brother laser printer and to an Epson inkjet.

Interestingly, on the laser printer, if I select two-sided printing the behavior changes a bit: When printing directly from Scrivener, the odd pages print as described above (header but no footer) but the even pages print the footer but no header. Again, if I save to a PDF and print it from Preview, then the headers and footers are present on all pages.

Am I missing something here? Other than selecting “Print” or “Save to PDF” I’m doing everything identically. Obviously I can always save to PDF and print from there, but I’d prefer not to have to take the extra step.

My setup:

  • Scrivener version 2.3
  • Mac OS version 10.7.4
  • First-generation Mac Pro tower (four Xeon cores)
  • 5 GB of RAM

This sounds like a printer problem. The printer is responsible for passing the necessary bounding sizes to the application; it sounds as though the printer is telling Scrivener it has more room to print on the page than it really does - printers each have a differing non-printing border around the page.

Go to File > Page Setup, then, under “Paper Size”, with the correct paper size selected select “Manage Custom Sizes…” form the bottom of the list. Under “Non-Printable Area”, select “User Defined” and then experiment with the “Bottom” value, making it a little bigger.

All the best,
Keith

Keith,

Thanks for the very quick response. I went into ‘page setup’ as you suggested. Everything looked correct (page size set to “US Letter”) so I tried changing the paper size to “US Legal” and things were even worse (text right down to the very bottom of the sheet). However, I when I switched back to “US Letter”, printing started working correctly. So the problem seems to be resolved.

One other thing, though – in the printer settings under “System Preferences” I have the default printer set to “last printer used”. This seems to work for other apps (e.g. Preview) but when I print from Scrivener it always seems to default to my inket printer even though the laser printer is the one I last printed from. Any ideas on why that may be happening?

I’m afraid not, no. The printer selected is entirely dealt with by OS X. There isn’t a single line of code in Scrivener that touches that sort of thing. Once an app invokes the print panel (which is automatic), OS X deals with everything else. Could it be selecting the last printer you used within the app?

All the best,
Keith