Overriding Bulleted List Indent/Tab Stops in Compile Style

All of the bulleted lists in my manuscript are assigned a paragraph style. I use this to provide some spacing around the lists when they go into the final compiled PDF.

I’d like to adjust the indentation/tab stops for these, but I’m not sure if the best option is going to be manually setting them in the manuscript and invoking ‘Preserve Formatting’ or if I can wrangle something with a compile style.

Naturally, I’d prefer to do it with a compile style, but I’ve been unsuccessful in doing so. Perhaps I’m missing a trick?

What I’ve tried so far: I’ve tried copying formatting and pasting into the style and also setting them manually in the style with no luck; in both cases, including font family and size information (just to try everything!). I’ve also tried playing with tab stops in section layouts (both with preserve tab stops on and off) also with no luck.

So, would it be best to do this manually?

Unfortunately, you’re probably best doing this directly. You could (in theory) use a style for this, but the trouble with that is that each level of a list has different tabs and indents, and there’s no way of setting up different tabs and indents for each level of a styled list in Compile.

All the best,

Thank you, Keith!

Come to think of it, none my lists are nested. Where am I going wrong with styles?

Hmm, difficult to say. Take a look at the attached sample project, though. This contains two lists. The second list has a paragraph style applied, which is overridden during Compile.

To achieve this, I just selected the list and created a paragraph style from it. Then in Compile, I added the style to the “Styles” list and changed the tab, indents and line spacing settings.

All the best,
LIstStyleOverride.zip (69 KB)

Thanks so much for that. I’ve been investigating and it seems something in my project or my compile style is clobbering the tab stops.I’ve been through a number of steps but all produce the same result: no change in the tab stops. I’m going to try rebuilding the compile style and maybe deleting and reapplying the list paragraph style. If that fails, I’ll send in a copy of the project.

Thank you again for the help.

No problem - let me know when you send us the project so that I can look out for it in the support queue.
All the best,

A small, but big, update. It’s working, but there appears to be a bug. I’ve not fully investigated it so I don’t have solid reproduction steps but it appears that if you add or change bullets after applying the style, it overrides the compile formatting. Perhaps expected behaviour, but not by me . :mrgreen:

Whilst I’ve got your eyes – 3.1.2: any time soon? Publishing in 10 days but the PDF is missing its outline and some page tops are going walkabout. 8)

Thanks again!

Hmm, that doesn’t sound right, as the Compile style should get applied over the top - is the list losing its style somehow perhaps? If you can find a reproduction case or put together an example, please let me know.

I can’t give a date on 3.1.2, but it will be longer than 10 days, I’m afraid. To fix the wandering top margins, turn off widow and orphan control. For the outline, there’s a bug whereby it only gets included if you turn on “Optimise for print-on-demand services” (i.e. exactly the opposite of what should happen).

All the best,

This doesn’t even work in my project. Not to mention it kills all the internal links in the PDF. I’m having trouble fathoming publishing a technical book without a useful ToC to move around in it. I’ve tried going back to 3.0.3 but it seems to have a bug handling some of my images that’s since been fixed in 3.1.x.